aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/template-glib/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/template-glib/APKBUILD b/testing/template-glib/APKBUILD
new file mode 100644
index 0000000000..6a505298fc
--- /dev/null
+++ b/testing/template-glib/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=template-glib
+pkgver=3.32.0
+pkgrel=0
+pkgdesc="library for template expansion which supports calling into GObject Introspection from templates"
+url="https://gitlab.gnome.org/GNOME/template-glib"
+arch="all"
+license="GPL-3.0-or-later"
+makedepends="meson vala gobject-introspection-dev glib-dev flex bison"
+subpackages="$pkgname-dev $pkgname-lang"
+source="https://download.gnome.org/sources/template-glib/${pkgver%.*}/template-glib-${pkgver}.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="00e275c15e7daac4c3cf3cd85d8e0700e8ec504a02b68f46754a8f177c6a2cecbbc9b2b5701c85c94d0c06dfa9b51425b37decfa1f619ccb2c7351c0ce1643e7 template-glib-3.32.0.tar.xz"