aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libbytesize/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/libbytesize/APKBUILD b/testing/libbytesize/APKBUILD
index c5f1c53c1c..52fa5c9d3a 100644
--- a/testing/libbytesize/APKBUILD
+++ b/testing/libbytesize/APKBUILD
@@ -3,14 +3,13 @@
pkgname=libbytesize
pkgver=1.3
pkgrel=0
-pkgdesc="A tiny library providing a C 'class' for working with arbitrary big sizes in bytes"
+pkgdesc="Library for working with arbitrary big sizes in bytes"
url="https://github.com/rhinstaller/libbytesize"
arch="all"
-license="LGPL"
-makedepends="pcre-dev mpfr-dev gmp-dev gettext-dev python3"
+license="LGPL-2.1-or-later"
+makedepends="gettext-dev gmp-dev mpfr-dev pcre-dev python3"
subpackages="$pkgname-dev $pkgname-lang py-$pkgname:py"
-source="https://github.com/storaged-project/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/"$pkgname-$pkgver
+source="https://github.com/storaged-project/libbytesize/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
build() {
cd "$builddir"
@@ -25,7 +24,7 @@ package() {
py() {
pkgdesc="Python bindings for $pkgname"
-
+
mkdir -p "$subpkgdir"/usr/lib
mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
}