aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/sysklogd/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/sysklogd/APKBUILD b/main/sysklogd/APKBUILD
index 8472266e58..adf2f73ecf 100644
--- a/main/sysklogd/APKBUILD
+++ b/main/sysklogd/APKBUILD
@@ -9,6 +9,7 @@ license="GPL BSD"
subpackages="$pkgname-doc"
depends=""
makedepends="linux-headers"
+options="!check" # requires kernel sources to build oops.ko
source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.gz
sysklogd.logrotate
sysklogd.daily
@@ -25,12 +26,12 @@ source="http://www.infodrom.org/projects/$pkgname/download/$pkgname-$pkgver.tar.
builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $builddir
+ cd "$builddir"
make CFLAGS="$CFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
}
package() {
- cd $builddir
+ cd "$builddir"
make INSTALL="install -D" prefix="$pkgdir" install
install -D -m644 "$srcdir"/sysklogd.logrotate \