aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/nmap/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/nmap/APKBUILD b/main/nmap/APKBUILD
index b2dd5ed2e5..a71a7e0f1a 100644
--- a/main/nmap/APKBUILD
+++ b/main/nmap/APKBUILD
@@ -1,13 +1,13 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=nmap
pkgver=7.70
-pkgrel=2
+pkgrel=3
pkgdesc="A network exploration tool and security/port scanner"
url="http://nmap.org"
arch="all"
license="custom"
depends=""
-makedepends="libpcap-dev openssl-dev lua-dev linux-headers"
+makedepends="linux-headers openssl-dev libpcap-dev pcre-dev zlib-dev libssh2-dev lua5.3-dev"
options="!check" #FIXME: fails on armhf and aarch64
subpackages="
$pkgname-doc
@@ -34,11 +34,13 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--without-zenmap \
- --with-liblua=/usr/include \
- --with-openssl=/usr/lib
-
- # fix LUA libs linking order
- make "LUA_LIBS=../liblua/liblua.a -ldl -lm"
+ --with-openssl=yes \
+ --with-libpcap=yes \
+ --with-libpcre=yes \
+ --with-libz=yes \
+ --with-libssh2=yes \
+ --with-liblua=/usr/lua5.3
+ make
}
check() {