aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/autossh/APKBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/community/autossh/APKBUILD b/community/autossh/APKBUILD
index 42a2725d32..7d02f10ed3 100644
--- a/community/autossh/APKBUILD
+++ b/community/autossh/APKBUILD
@@ -2,22 +2,19 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=autossh
pkgver=1.4g
-pkgrel=0
+pkgrel=1
pkgdesc="Automatically restart SSH sessions and tunnels"
-url="http://www.harding.motd.ca/autossh/"
+url="https://www.harding.motd.ca/autossh/"
arch="all"
-license="BSD"
+license="MIT"
depends="openssh-client"
-makedepends=""
options="!check" # no unit tests available
subpackages="$pkgname-doc"
source="http://www.harding.motd.ca/autossh/autossh-$pkgver.tgz
README.alpine
"
-builddir="$srcdir/autossh-$pkgver"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,7 +27,6 @@ build() {
}
package() {
- cd "$builddir"
install -D -m755 autossh \
"$pkgdir"/usr/bin/autossh
install -D -m644 CHANGES \
@@ -44,7 +40,7 @@ package() {
install -D -m644 autossh.1 \
"$pkgdir"/usr/share/man/man1/autossh.1
install -Dm644 "$srcdir"/README.alpine \
- "$pkgdir"/usr/share/doc/$pkgname/README.alpine
+ "$pkgdir"/usr/share/doc/$pkgname/README.alpine
}
sha512sums="499b560d978736f4e764d5d828282fdaba1cbf94811ae6be0be5434d9c1cdc6ca5513d728b6372aa243843cb1b91e61cfc5fdeb77ddb0b6a7ce027218ba67466 autossh-1.4g.tgz