aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/haxe/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index ccdabc531b..1018a7c0fd 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -29,20 +29,20 @@ _builddir="$srcdir/$pkgname-$pkgver$_versuffix"
build() {
cd "$_builddir"
- rmdir libs extra/haxelib_src || return 1
- mv "$srcdir"/haxelib-${_commit_haxelib} extra/haxelib_src || return 1
- mv "$srcdir"/ocamllibs-${_commit_ocamllibs} libs || return 1
+ rmdir libs extra/haxelib_src
+ mv "$srcdir"/haxelib-${_commit_haxelib} extra/haxelib_src
+ mv "$srcdir"/ocamllibs-${_commit_ocamllibs} libs
# Check to see if ocamlopt exists. If not, bytecompile everything.
- command -v ocamlopt && make -j1 || make -j1 BYTECODE=1 || return 1
- make -j1 tools || return 1
+ command -v ocamlopt && make -j1 || make -j1 BYTECODE=1
+ make -j1 tools
}
check() {
cd "$_builddir"
- ./haxe -version || return 1
- ./haxelib version || return 1
+ ./haxe -version
+ ./haxelib version
}
package() {