aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-pyldap/APKBUILD (renamed from community/py-pyldap/APKBUILD)26
1 files changed, 5 insertions, 21 deletions
diff --git a/community/py-pyldap/APKBUILD b/community/py3-pyldap/APKBUILD
index 73eada5919..9e44c5e729 100644
--- a/community/py-pyldap/APKBUILD
+++ b/community/py3-pyldap/APKBUILD
@@ -1,6 +1,6 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
-pkgname=py-pyldap
+pkgname=py3-pyldap
_pkgname=python-ldap
pkgver=3.2.0
pkgrel=0
@@ -8,41 +8,25 @@ pkgdesc="Python modules for implementing LDAP clients"
url="https://github.com/python-ldap/python-ldap"
arch="all"
options="!check" # depends on slapdtest
-license="PSF"
+license="Python-2.0"
depends="libldap py3-asn1 py3-asn1-modules"
makedepends="python3-dev py3-setuptools openldap-dev"
checkdepends="openldap openldap-clients"
-subpackages="py3-$_pkgname:_py3"
source="https://github.com/$_pkgname/$_pkgname/archive/$_pkgname-$pkgver.tar.gz"
+replaces="py-pyldap"
+provides="py-pyldap=$pkgver-r$pkgrel"
builddir="$srcdir/$_pkgname-$_pkgname-$pkgver"
build() {
- cd "$builddir"
-
python3 setup.py build
}
check() {
- cd "$builddir"
-
python3 setup.py test
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="142ac4f98dfad62abb9ce47822771b4e431e4d86251f7139d99d92d0005cd6c2c1bec2b12e7ab96aa2f9d044e68623d4ddeecfc3a1820c19cd163ddd89355cd0 python-ldap-3.2.0.tar.gz"