aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-google-auth/10-use-mock-from-standard-library.patch54
-rw-r--r--community/py3-google-auth/APKBUILD22
2 files changed, 42 insertions, 34 deletions
diff --git a/community/py3-google-auth/10-use-mock-from-standard-library.patch b/community/py3-google-auth/10-use-mock-from-standard-library.patch
index d0d1f0908f..9b7c357532 100644
--- a/community/py3-google-auth/10-use-mock-from-standard-library.patch
+++ b/community/py3-google-auth/10-use-mock-from-standard-library.patch
@@ -1,5 +1,5 @@
diff --git a/tests/compute_engine/test__metadata.py b/tests/compute_engine/test__metadata.py
-index bf48882..59872ca 100644
+index 0898e1f..6a44585 100644
--- a/tests/compute_engine/test__metadata.py
+++ b/tests/compute_engine/test__metadata.py
@@ -16,7 +16,7 @@ import datetime
@@ -12,7 +12,7 @@ index bf48882..59872ca 100644
from six.moves import http_client
from six.moves import reload_module
diff --git a/tests/compute_engine/test_credentials.py b/tests/compute_engine/test_credentials.py
-index ee415db..22352b8 100644
+index ec9d13b..555306c 100644
--- a/tests/compute_engine/test_credentials.py
+++ b/tests/compute_engine/test_credentials.py
@@ -14,7 +14,7 @@
@@ -25,7 +25,7 @@ index ee415db..22352b8 100644
from google.auth import _helpers
diff --git a/tests/conftest.py b/tests/conftest.py
-index c9e3f84..02896fe 100644
+index 2ccc132..de254f2 100644
--- a/tests/conftest.py
+++ b/tests/conftest.py
@@ -14,7 +14,7 @@
@@ -38,7 +38,7 @@ index c9e3f84..02896fe 100644
diff --git a/tests/crypt/test__python_rsa.py b/tests/crypt/test__python_rsa.py
-index d13105f..564b85d 100644
+index 08b9503..e0be561 100644
--- a/tests/crypt/test__python_rsa.py
+++ b/tests/crypt/test__python_rsa.py
@@ -15,7 +15,7 @@
@@ -51,7 +51,7 @@ index d13105f..564b85d 100644
import pytest
import rsa
diff --git a/tests/oauth2/test__client.py b/tests/oauth2/test__client.py
-index 3ec7fc6..96c5330 100644
+index 052390a..beca8e8 100644
--- a/tests/oauth2/test__client.py
+++ b/tests/oauth2/test__client.py
@@ -16,7 +16,7 @@ import datetime
@@ -64,12 +64,12 @@ index 3ec7fc6..96c5330 100644
import six
from six.moves import http_client
diff --git a/tests/oauth2/test_credentials.py b/tests/oauth2/test_credentials.py
-index 922c3bb..cced0ed 100644
+index af10f2f..5d9e239 100644
--- a/tests/oauth2/test_credentials.py
+++ b/tests/oauth2/test_credentials.py
-@@ -16,7 +16,7 @@ import datetime
- import json
- import os
+@@ -18,7 +18,7 @@ import os
+ import pickle
+ import sys
-import mock
+from unittest import mock
@@ -77,7 +77,7 @@ index 922c3bb..cced0ed 100644
from google.auth import _helpers
diff --git a/tests/oauth2/test_id_token.py b/tests/oauth2/test_id_token.py
-index 360f92f..61f8499 100644
+index 980a8e9..d837c0e 100644
--- a/tests/oauth2/test_id_token.py
+++ b/tests/oauth2/test_id_token.py
@@ -14,7 +14,7 @@
@@ -90,7 +90,7 @@ index 360f92f..61f8499 100644
from google.auth import exceptions
diff --git a/tests/oauth2/test_service_account.py b/tests/oauth2/test_service_account.py
-index 54ac0f5..e8fc47a 100644
+index 0f9d460..ba0f0fe 100644
--- a/tests/oauth2/test_service_account.py
+++ b/tests/oauth2/test_service_account.py
@@ -16,7 +16,7 @@ import datetime
@@ -103,7 +103,7 @@ index 54ac0f5..e8fc47a 100644
from google.auth import _helpers
from google.auth import crypt
diff --git a/tests/test__cloud_sdk.py b/tests/test__cloud_sdk.py
-index 58c7270..39ad93f 100644
+index c5c5c27..96b6327 100644
--- a/tests/test__cloud_sdk.py
+++ b/tests/test__cloud_sdk.py
@@ -17,7 +17,7 @@ import json
@@ -116,7 +116,7 @@ index 58c7270..39ad93f 100644
from google.auth import _cloud_sdk
diff --git a/tests/test__default.py b/tests/test__default.py
-index 3fb0fa1..c2db09d 100644
+index 2c86f3f..ba88982 100644
--- a/tests/test__default.py
+++ b/tests/test__default.py
@@ -15,7 +15,7 @@
@@ -129,7 +129,7 @@ index 3fb0fa1..c2db09d 100644
from google.auth import _default
diff --git a/tests/test__oauth2client.py b/tests/test__oauth2client.py
-index 832b24f..151574b 100644
+index 520f943..b1d2ece 100644
--- a/tests/test__oauth2client.py
+++ b/tests/test__oauth2client.py
@@ -16,7 +16,7 @@ import datetime
@@ -142,7 +142,7 @@ index 832b24f..151574b 100644
import oauth2client.contrib.gce
import oauth2client.service_account
diff --git a/tests/test_app_engine.py b/tests/test_app_engine.py
-index 70fa5ca..177b2c4 100644
+index 9559a2c..29ca4f0 100644
--- a/tests/test_app_engine.py
+++ b/tests/test_app_engine.py
@@ -14,7 +14,7 @@
@@ -155,7 +155,7 @@ index 70fa5ca..177b2c4 100644
from google.auth import app_engine
diff --git a/tests/test_iam.py b/tests/test_iam.py
-index cc09085..cef1cb6 100644
+index 52ab9bd..f852cca 100644
--- a/tests/test_iam.py
+++ b/tests/test_iam.py
@@ -16,7 +16,7 @@ import base64
@@ -168,7 +168,7 @@ index cc09085..cef1cb6 100644
from six.moves import http_client
diff --git a/tests/test_impersonated_credentials.py b/tests/test_impersonated_credentials.py
-index 68a2af8..fc2b8d3 100644
+index 1cfcc7c..4449762 100644
--- a/tests/test_impersonated_credentials.py
+++ b/tests/test_impersonated_credentials.py
@@ -16,7 +16,7 @@ import datetime
@@ -181,7 +181,7 @@ index 68a2af8..fc2b8d3 100644
from six.moves import http_client
diff --git a/tests/test_jwt.py b/tests/test_jwt.py
-index 4a64717..fd5a565 100644
+index b0c6e48..ed6ce28 100644
--- a/tests/test_jwt.py
+++ b/tests/test_jwt.py
@@ -17,7 +17,7 @@ import datetime
@@ -194,12 +194,12 @@ index 4a64717..fd5a565 100644
from google.auth import _helpers
diff --git a/tests/transport/test_grpc.py b/tests/transport/test_grpc.py
-index c98dcff..6360dd7 100644
+index ca12385..9fdb92d 100644
--- a/tests/transport/test_grpc.py
+++ b/tests/transport/test_grpc.py
-@@ -14,7 +14,7 @@
-
+@@ -15,7 +15,7 @@
import datetime
+ import time
-import mock
+from unittest import mock
@@ -207,20 +207,20 @@ index c98dcff..6360dd7 100644
from google.auth import _helpers
diff --git a/tests/transport/test_requests.py b/tests/transport/test_requests.py
-index 311992a..9396fcc 100644
+index f0321c8..f393950 100644
--- a/tests/transport/test_requests.py
+++ b/tests/transport/test_requests.py
-@@ -12,7 +12,7 @@
- # See the License for the specific language governing permissions and
- # limitations under the License.
+@@ -16,7 +16,7 @@ import datetime
+ import functools
+ import freezegun
-import mock
+from unittest import mock
+ import pytest
import requests
import requests.adapters
- from six.moves import http_client
diff --git a/tests/transport/test_urllib3.py b/tests/transport/test_urllib3.py
-index a119b74..a3e9afb 100644
+index 1d7ce5a..627b33c 100644
--- a/tests/transport/test_urllib3.py
+++ b/tests/transport/test_urllib3.py
@@ -12,7 +12,7 @@
diff --git a/community/py3-google-auth/APKBUILD b/community/py3-google-auth/APKBUILD
index b30f48f760..03da0e8048 100644
--- a/community/py3-google-auth/APKBUILD
+++ b/community/py3-google-auth/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-google-auth
_pyname=google-auth
-pkgver=1.7.2
+pkgver=1.11.0
pkgrel=0
pkgdesc="Google authentication library for Python."
url="https://google-auth.readthedocs.io/en/latest/"
@@ -10,15 +10,23 @@ arch="noarch"
license="Apache-2.0"
depends="
python3
- py3-cachetools<3.2
+ py3-cachetools<5.0
py3-asn1-modules
py3-rsa<4.1
py3-setuptools
py3-six
"
-checkdepends="py3-certifi py3-flask py3-oauth2client py3-pytest py3-pytest-cov
- py3-pytest-localserver py3-requests py3-requests-oauthlib py3-urllib3
- py3-cryptography"
+checkdepends="
+ py3-flask
+ py3-freezegun
+ py3-oauth2client
+ py3-pytest
+ py3-pytest-cov
+ py3-pytest-localserver
+ py3-requests
+ py3-urllib3
+ py3-cryptography
+ "
source="https://files.pythonhosted.org/packages/source/g/$_pyname/$_pyname-$pkgver.tar.gz
10-use-mock-from-standard-library.patch
"
@@ -37,5 +45,5 @@ check() {
pytest-3 # skips grpc tests
}
-sha512sums="36802b0923ddab01cdd5acaa7e7a873597968378dd52a8ab5724a357c5ba34df81a3d444b62f68e9670e62b282b542e1c98afe591df71b152548946e9f43c271 google-auth-1.7.2.tar.gz
-4242765bce157f7e3ba42b668396d7629b78a389f82832960b689741c0f30f6a1a3d07e217b37c6c6515813b6a7783e1cc9308046bc38d9fcb0c596bf3f896ff 10-use-mock-from-standard-library.patch"
+sha512sums="ef51884a1e6724c74787918facb409f693cc0271ac193155273f102e67b31a857453911d541de0d50081812ff3654de04b0d853d33e9ab9e11e88cf7ae2d6a51 google-auth-1.11.0.tar.gz
+34c6eeaf2e83370ec78c5cfd99b54940a3c3027ec361c162c8d5f653426d3fca48705ad76b97660489ffd5c9e0be49a5f9dd5a4df9831777cd6855c9288a9150 10-use-mock-from-standard-library.patch"