aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/surf/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/surf/APKBUILD b/testing/surf/APKBUILD
index d8e95ce1f5..6b62d9f925 100644
--- a/testing/surf/APKBUILD
+++ b/testing/surf/APKBUILD
@@ -1,3 +1,4 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
pkgname=surf
@@ -14,6 +15,13 @@ source="$pkgname-$pkgver.tar.gz::https://dl.suckless.org/$pkgname/$pkgname-$pkgv
builddir="$srcdir/"$pkgname-$pkgver
subpackages="$pkgname-doc"
+prepare() {
+ default_prepare
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/-s//;s/=/+=/}' \
+ "$builddir"/config.mk
+}
+
build() {
cd "$builddir"
make