aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-ansi2html/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/testing/py3-ansi2html/APKBUILD b/testing/py3-ansi2html/APKBUILD
index e447a9a663..549d4cbccc 100644
--- a/testing/py3-ansi2html/APKBUILD
+++ b/testing/py3-ansi2html/APKBUILD
@@ -3,26 +3,24 @@
pkgname=py3-ansi2html
_pkgname=ansi2html
pkgver=1.5.2
-pkgrel=3
+pkgrel=4
pkgdesc="Convert text with ANSI color codes to HTML"
url="https://github.com/ralphbean/ansi2html"
arch="noarch"
license="LGPL-3.0-or-later"
-replaces="py-ansi2html" # for backwards compatibility
-provides="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
-depends="python3 py3-six"
-makedepends="py3-setuptools python3-dev"
+depends="python3 py3-six py3-setuptools"
+makedepends="python3-dev"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-ansi2html" # for backwards compatibility
+provides="py-ansi2html=$pkgver-r$pkgrel" # for backwards compatibility
+
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}