aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/hermes/APKBUILD8
-rw-r--r--community/hermes/fix-string-declares-ppc64le.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/community/hermes/APKBUILD b/community/hermes/APKBUILD
index 30b184c556..0e71ea0ddf 100644
--- a/community/hermes/APKBUILD
+++ b/community/hermes/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=hermes
pkgver=1.9
-pkgrel=6
+pkgrel=7
pkgdesc="Hermes is an anti-spam transparent SMTP proxy"
url="https://hermes-project.com/"
-arch="all !ppc64le"
+arch="all"
license="GPL"
makedepends="libspf2-dev sqlite-dev perl gettext-dev openssl-dev doxygen"
subpackages="$pkgname-doc"
source="https://hermes-project.com/files/${pkgname}-${pkgver}.tar.bz2
Utils.cpp.patch
openssl-1.1.patch
+ fix-string-declares-ppc64le.patch
"
builddir=${srcdir}/${pkgname}-${pkgver}
@@ -34,4 +35,5 @@ package() {
sha512sums="9861177cee7d4936e2221f3ff9f60c030385d6c2ab1cbc320f4e03880220117c580a11188e011f9051c79691e1ab8399c03be8cbbc4f18519a1a9b966bf767b9 hermes-1.9.tar.bz2
ac5859bed41c5b484adf8b42d66d69cf49966df84e664f9f6978d3c4fa6200858ea024c6631c2f1fd02c09d7f95e6102b3fce68b3f92f5223c4f8a253fd57d0c Utils.cpp.patch
-07a76a139dd6eae044aac4e2fd1e072185b9b1f94d4d31a18aae7e9a0ec3f29d97edaad861e0383688c4b76731d36f893085712eaba7fd52016bdcef2084fa43 openssl-1.1.patch"
+07a76a139dd6eae044aac4e2fd1e072185b9b1f94d4d31a18aae7e9a0ec3f29d97edaad861e0383688c4b76731d36f893085712eaba7fd52016bdcef2084fa43 openssl-1.1.patch
+e8f3724fef1a24e022b32fc1802488fe0e8a58befd13c1af3d5b9366826a172abc91f1c8dcd90248744de1103f2d5076f5dd345fc8bbc020cfecbc0b344f67eb fix-string-declares-ppc64le.patch"
diff --git a/community/hermes/fix-string-declares-ppc64le.patch b/community/hermes/fix-string-declares-ppc64le.patch
new file mode 100644
index 0000000000..325087ada1
--- /dev/null
+++ b/community/hermes/fix-string-declares-ppc64le.patch
@@ -0,0 +1,10 @@
+--- a/src/Utils.cpp
++++ b/src/Utils.cpp
+@@ -20,6 +20,7 @@
+ #include "Utils.h"
+
+ #include <unistd.h>
++#include <string.h>
+
+ extern Configfile cfg;
+ extern LOGGER_CLASS hermes_log;