aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/gitea/APKBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/testing/gitea/APKBUILD b/testing/gitea/APKBUILD
index 140c5bb0be..14cd3226bd 100644
--- a/testing/gitea/APKBUILD
+++ b/testing/gitea/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: 7heo <7heo@mail.com>
pkgname=gitea
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="A self-hosted Git service written in Go"
url="http://gitea.io/"
arch="all"
@@ -48,6 +48,7 @@ package() {
"$pkgdir"/var/lib/$pkgname/avatars \
"$pkgdir"/var/lib/$pkgname/attachements \
"$pkgdir"/var/cache/$pkgname/sessions \
+ "$pkgdir"/var/cache/$pkgname/conf \
"$pkgdir"/var/log/$pkgname \
"$pkgdir"/etc/$pkgname/conf || return 1
@@ -60,7 +61,8 @@ package() {
install -D -m 0664 -o gitea -g www-data "$srcdir"/${pkgname}.ini \
"$pkgdir"/etc/$pkgname/conf/app.ini || return 1
- mv options/* "$pkgdir"/etc/$pkgname/conf/ || return 1
+ mv options/* "$pkgdir"/var/cache/$pkgname/conf || return 1
+ chown gitea:www-data -R "$pkgdir"/etc/$pkgname/conf || return 1
mv public templates "$pkgdir"/usr/share/webapps/$pkgname/ || return 1