aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/kcalendarcore/APKBUILD (renamed from testing/kcalcore/APKBUILD)23
1 files changed, 17 insertions, 6 deletions
diff --git a/testing/kcalcore/APKBUILD b/community/kcalendarcore/APKBUILD
index 496e242c4d..a410355e4e 100644
--- a/testing/kcalcore/APKBUILD
+++ b/community/kcalendarcore/APKBUILD
@@ -1,19 +1,28 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
-pkgname=kcalcore
-pkgver=19.08.2
+pkgname=kcalendarcore
+pkgver=5.63.0
pkgrel=0
pkgdesc="The KDE calendar access library"
arch="all"
-url="https://api.kde.org/kdepim/kcalcore/html"
+url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later"
depends_dev="qt5-qtbase-dev libical-dev"
makedepends="$depends_dev extra-cmake-modules"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
subpackages="$pkgname-dev"
+replaces="kcalcore"
+
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -21,11 +30,13 @@ build() {
}
check() {
+ cd "$builddir"/build
# testrecurtodo, testreadrecurrenceid and testicaltimezones are broken
CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "test(recurtodo|readrecurrenceid|icaltimezones)"
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
-sha512sums="7f89f986b6ef91686d95888c3aa637a7072dbdc3054cad1ecc6e0cb16c08d0be25f578b9d8779d068c1cb3cc7c2eea42cb10d5136c62398a0a5de39a7beee6d4 kcalcore-19.08.2.tar.xz"
+sha512sums="11b2a4e7d37ee435778a19f2dbfb9f5084d951bc5dafd8acbb6e36ae919fa97594bdfba6c542a63694745ae14c289b7a4d67136b0cefd70fed4212a0118be9cd kcalendarcore-5.63.0.tar.xz"