aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/xeyes/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/xeyes/APKBUILD b/community/xeyes/APKBUILD
index 51128ffabd..b43ff3476b 100644
--- a/community/xeyes/APKBUILD
+++ b/community/xeyes/APKBUILD
@@ -14,10 +14,15 @@ install=""
subpackages="$pkgname-doc"
source="http://www.x.org/releases/individual/app/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+ update_config_guess || return 1
+}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--prefix=/usr \
--datarootdir=/usr/share \
@@ -26,7 +31,7 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}