aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/tau/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/testing/tau/APKBUILD b/testing/tau/APKBUILD
index 95cc6ec4e0..7a67ede0b2 100644
--- a/testing/tau/APKBUILD
+++ b/testing/tau/APKBUILD
@@ -14,6 +14,13 @@ subpackages="$pkgname-lang"
source="https://gitlab.gnome.org/World/Tau/uploads/fdf09640e3837ad509f5c4b1da0c26e3/tau-$pkgver.tar.xz"
build() {
+ # Fails to compile libbacktrace-sys otherwise
+ case "$CARCH" in
+ x86)
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ ;;
+ esac
+
meson \
--prefix=/usr \
--sysconfdir=/etc \