aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/chromium/APKBUILD2
-rw-r--r--community/mongodb/APKBUILD2
-rw-r--r--community/wiredtiger/APKBUILD2
-rw-r--r--main/qemu/APKBUILD2
-rw-r--r--main/snappy/APKBUILD34
-rw-r--r--main/snappy/fix-GetHashTable.patch16
-rw-r--r--main/snappy/fix-UnalignedCopy64.patch13
-rw-r--r--testing/ceph/APKBUILD2
-rw-r--r--testing/leveldb/APKBUILD2
-rw-r--r--testing/monetdb/APKBUILD2
-rw-r--r--testing/mongo-c-driver/APKBUILD2
-rw-r--r--testing/qt5-qtwebengine/APKBUILD2
-rw-r--r--testing/rocksdb/APKBUILD2
13 files changed, 28 insertions, 55 deletions
diff --git a/community/chromium/APKBUILD b/community/chromium/APKBUILD
index 8f8b28a763..5fbfa32c15 100644
--- a/community/chromium/APKBUILD
+++ b/community/chromium/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=chromium
pkgver=64.0.3282.168
-pkgrel=1
+pkgrel=2
pkgdesc="chromium web browser"
url="http://www.chromium.org/"
arch="x86_64"
diff --git a/community/mongodb/APKBUILD b/community/mongodb/APKBUILD
index 8991064513..0af848d50d 100644
--- a/community/mongodb/APKBUILD
+++ b/community/mongodb/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Filipp Andronov <filipp.andronov@gmail.com>
pkgname=mongodb
pkgver=4.0.0
-pkgrel=0
+pkgrel=1
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64 ppc64le'
diff --git a/community/wiredtiger/APKBUILD b/community/wiredtiger/APKBUILD
index 7e7b81659e..25c4eb05ff 100644
--- a/community/wiredtiger/APKBUILD
+++ b/community/wiredtiger/APKBUILD
@@ -4,7 +4,7 @@
pkgname=wiredtiger
mongodb_version=3.6.3
pkgver=3.0.0.$mongodb_version
-pkgrel=0
+pkgrel=1
pkgdesc="High performance, scalable, production quality, NoSQL, Open Source extensible platform for data management"
url="http://www.wiredtiger.com"
arch="x86_64"
diff --git a/main/qemu/APKBUILD b/main/qemu/APKBUILD
index 2495b83f45..c3cfe14ef3 100644
--- a/main/qemu/APKBUILD
+++ b/main/qemu/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qemu
pkgver=2.12.0
-pkgrel=3
+pkgrel=4
pkgdesc="QEMU is a generic machine emulator and virtualizer"
url="http://qemu.org/"
arch="all"
diff --git a/main/snappy/APKBUILD b/main/snappy/APKBUILD
index 749ede109e..9b1333ae38 100644
--- a/main/snappy/APKBUILD
+++ b/main/snappy/APKBUILD
@@ -1,37 +1,39 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=snappy
-pkgver=1.1.4
-pkgrel=4
+pkgver=1.1.7
+pkgrel=0
pkgdesc="Fast compression and decompression library"
-url="http://google.github.io/snappy/"
+url="https://google.github.io/snappy/"
arch="all"
license="BSD-3-Clause"
+makedepends="cmake"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc"
-source="https://github.com/google/snappy/releases/download/$pkgver/snappy-$pkgver.tar.gz
- fix-UnalignedCopy64.patch
- fix-GetHashTable.patch
- "
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/google/snappy/archive/$pkgver.tar.gz"
build() {
cd "$builddir"
- ./configure \
- --prefix=/usr \
- --disable-static
- make
+ cmake . \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DBUILD_SHARED_LIBS=ON
+ cmake --build .
}
check() {
cd "$builddir"
- make check
+ ctest --verbose
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
+
+ local file; for file in AUTHORS CONTRIBUTING.md COPYING NEWS README.md \
+ format_description.txt framing_format.txt; do
+ install -m644 -D $file "$pkgdir"/usr/share/doc/$pkgname/$file
+ done
}
-sha512sums="4f522f1d541e3f00d82ccaf6dda5c6ede28d4db19c53717003d8057261fe8630516ed6ff2a28615da032e0de9c6200b560ed5fce4f8714df9916d50d6a7c2178 snappy-1.1.4.tar.gz
-a086dbdfe2cb21419b33c2f8a2739224a8e843f2c6a51715100c723b9fbd9aed14bcfa791c20dae785b33ac1d1cf4812ed2c5c5d4058c5b8e56a0e004e9a8c60 fix-UnalignedCopy64.patch
-8db7a634c9147286f01eb4bd0a5ff2138540c06acad5fb77aa2977f7b64a19b91ff0f886f650b0a38834a33895f7a1dd4bcfb93af7f6676d59e3fdb8b6efbea0 fix-GetHashTable.patch"
+sha512sums="32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf snappy-1.1.7.tar.gz"
diff --git a/main/snappy/fix-GetHashTable.patch b/main/snappy/fix-GetHashTable.patch
deleted file mode 100644
index 0fdf88e472..0000000000
--- a/main/snappy/fix-GetHashTable.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix for armhf.
-
-See: https://groups.google.com/d/msg/snappy-compression/uhELq553TrI/J34d3D8_BwAJ
- https://bugs.alpinelinux.org/issues/8921
-
---- a/snappy.cc
-+++ b/snappy.cc
-@@ -323,7 +323,7 @@
- *table_size = 256;
- } else {
- // Since table size must be a power of 2, round up to the next power of 2.
-- *table_size = 1 << (std::numeric_limits<size_t>::digits -
-+ *table_size = 1 << std::max(1, std::numeric_limits<size_t>::digits -
- __builtin_clzll(input_size - 1));
- }
- if (*table_size <= ARRAYSIZE(small_table_)) {
diff --git a/main/snappy/fix-UnalignedCopy64.patch b/main/snappy/fix-UnalignedCopy64.patch
deleted file mode 100644
index ea64639a17..0000000000
--- a/main/snappy/fix-UnalignedCopy64.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/snappy.cc b/snappy.cc
-index 4bcea0b..2db94b7 100644
---- a/snappy.cc
-+++ b/snappy.cc
-@@ -89,7 +89,7 @@ size_t MaxCompressedLength(size_t source_len) {
- namespace {
-
- void UnalignedCopy64(const void* src, void* dst) {
-- memcpy(dst, src, 8);
-+ memmove(dst, src, 8);
- }
-
- void UnalignedCopy128(const void* src, void* dst) {
diff --git a/testing/ceph/APKBUILD b/testing/ceph/APKBUILD
index 79a5eb52f2..592b01276c 100644
--- a/testing/ceph/APKBUILD
+++ b/testing/ceph/APKBUILD
@@ -5,7 +5,7 @@
pkgname=ceph
pkgver=11.0.1
-pkgrel=7
+pkgrel=8
pkgdesc="User space components of the Ceph file system"
pkgusers="ceph"
pkggroups="ceph"
diff --git a/testing/leveldb/APKBUILD b/testing/leveldb/APKBUILD
index 391cf7ca0a..66ab128c63 100644
--- a/testing/leveldb/APKBUILD
+++ b/testing/leveldb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=leveldb
pkgver=1.20
-pkgrel=0
+pkgrel=1
pkgdesc="A fast and lightweight key/value database library by Google"
url="https://github.com/google/leveldb"
arch="all"
diff --git a/testing/monetdb/APKBUILD b/testing/monetdb/APKBUILD
index 3769f1fc65..87b70149d1 100644
--- a/testing/monetdb/APKBUILD
+++ b/testing/monetdb/APKBUILD
@@ -3,7 +3,7 @@
pkgname=monetdb
_pkgname=MonetDB
pkgver=11.29.7
-pkgrel=0
+pkgrel=1
pkgdesc="Column-oriented database management system"
url="https://www.monetdb.org/Home"
arch="all"
diff --git a/testing/mongo-c-driver/APKBUILD b/testing/mongo-c-driver/APKBUILD
index 5663509c08..56ed6d7006 100644
--- a/testing/mongo-c-driver/APKBUILD
+++ b/testing/mongo-c-driver/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=mongo-c-driver
pkgver=1.9.3
-pkgrel=0
+pkgrel=1
pkgdesc="Client library written in C for MongoDB"
url="https://github.com/mongodb/mongo-c-driver"
arch="all !x86 !armhf" # testsuite fails on x86 and armhf
diff --git a/testing/qt5-qtwebengine/APKBUILD b/testing/qt5-qtwebengine/APKBUILD
index 60a4886cc1..ee31d337cf 100644
--- a/testing/qt5-qtwebengine/APKBUILD
+++ b/testing/qt5-qtwebengine/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt5-qtwebengine
pkgver=5.10.1
-pkgrel=3
+pkgrel=4
pkgdesc="Qt5 - QtWebEngine components"
url="http://qt-project.org/"
# ppc64le: not supported
diff --git a/testing/rocksdb/APKBUILD b/testing/rocksdb/APKBUILD
index 1105851e69..978056fd2f 100644
--- a/testing/rocksdb/APKBUILD
+++ b/testing/rocksdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=rocksdb
pkgver=4.2
-pkgrel=1
+pkgrel=2
pkgdesc="A persistent key-value store for fast storage environments"
url="http://rocksdb.org"
arch="x86_64"