aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libfm/APKBUILD26
-rw-r--r--community/libfm/undef-G_DISABLE_ASSERT-earlier.patch17
-rw-r--r--community/pcmanfm/APKBUILD7
3 files changed, 22 insertions, 28 deletions
diff --git a/community/libfm/APKBUILD b/community/libfm/APKBUILD
index 2b08a417c1..9808dcb1d5 100644
--- a/community/libfm/APKBUILD
+++ b/community/libfm/APKBUILD
@@ -2,18 +2,29 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=libfm
-pkgver=1.3.0.2
-pkgrel=1
+pkgver=1.3.1
+pkgrel=0
pkgdesc="Library for file management"
url="https://wiki.lxde.org/en/PCManFM"
arch="all"
license="GPL-2.0-or-later"
-makedepends="gtk+2.0-dev menu-cache-dev udisks-dev intltool dbus-glib-dev
- libexif-dev vala gtk-doc automake autoconf libtool"
+makedepends="
+ autoconf
+ automake
+ dbus-glib-dev
+ gtk+2.0-dev
+ gtk-doc
+ intltool
+ libexif-dev
+ libtool
+ menu-cache-dev
+ udisks-dev
+ vala
+ "
options="libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/lxde/$pkgname/archive/$pkgver.tar.gz
- undef-G_DISABLE_ASSERT-earlier.patch
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/lxde/libfm/archive/$pkgver.tar.gz
"
prepare() {
default_prepare
@@ -44,5 +55,4 @@ package() {
mv "$pkgdir"/usr/include/libfm-1.0/ "$pkgdir"/usr/include/libfm
}
-sha512sums="c954c7210b6eee66ec265490e16fe91fe7995cd95b340f49197eec60a9af94f1ca0f67861dd5455c0deb81a10f5091cbf3dc471ed224477acdc081b48d036c69 libfm-1.3.0.2.tar.gz
-3bc242566402455a1e0c66e9b7962ddf92a4113a49e9e094e5d585b00649327352e45917f229606b7edfc35e9ba3a9ae8733457de5ca682e1ab7fdd869bcd03a undef-G_DISABLE_ASSERT-earlier.patch"
+sha512sums="82bbcb1b9c7d4543bcb075906bdc1554462b041ad936e2f0334ae478302b19808cdbfe6d0c86a039bbd72a2491f2d2ada61a324fe3933a8dde16a03d93bef2bc libfm-1.3.1.tar.gz"
diff --git a/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch b/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch
deleted file mode 100644
index 34bd7d0418..0000000000
--- a/community/libfm/undef-G_DISABLE_ASSERT-earlier.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/src/tests/test-fm-path.c
-+++ b/src/tests/test-fm-path.c
-@@ -19,12 +19,12 @@
- * MA 02110-1301, USA.
- */
-
--#include <fm.h>
--
- //ignore for test disabled asserts
- #ifdef G_DISABLE_ASSERT
- #undef G_DISABLE_ASSERT
- #endif
-+
-+#include <fm.h>
-
- #define TEST_PARSING(func, str_to_parse, ...) \
- G_STMT_START { \
diff --git a/community/pcmanfm/APKBUILD b/community/pcmanfm/APKBUILD
index 652e16a82d..abc5fa43d0 100644
--- a/community/pcmanfm/APKBUILD
+++ b/community/pcmanfm/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcmanfm
-pkgver=1.3.0
+pkgver=1.3.1
pkgrel=0
pkgdesc="Extremely fast and lightweight file manager"
arch="all"
@@ -10,7 +10,8 @@ url="https://wiki.lxde.org/en/PCManFM"
license="GPL-2.0-or-later"
makedepends="gtk+2.0-dev libfm-dev intltool"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz
+source="
+ https://downloads.sourceforge.net/pcmanfm/$pkgname-$pkgver.tar.xz
"
# secfixes:
@@ -39,4 +40,4 @@ package() {
"$pkgdir"/usr/share/applications/pcmanfm.desktop
}
-sha512sums="022e6e203a6cbba6531eb3dd21e0dd96687c42992015225f979a8df4539ddb0071f70d8619a7d804c0399424833af20181b8473a35a14b0fa1653e6fdbdfa367 pcmanfm-1.3.0.tar.xz"
+sha512sums="68fbc55b3ffd9da17c861d2cc41590a455ec2c0eb590ba4862f8a0ae01caac34a58645d847d318553ff588df20d355bbcbf1138a792cb45922eb04b047f681c4 pcmanfm-1.3.1.tar.xz"