aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/phodav/APKBUILD30
-rw-r--r--community/phodav/meson_build-udev.patch30
-rw-r--r--community/phodav/spice-webdavd.initd6
3 files changed, 12 insertions, 54 deletions
diff --git a/community/phodav/APKBUILD b/community/phodav/APKBUILD
index 4c6f8d156d..ef9e11c6c5 100644
--- a/community/phodav/APKBUILD
+++ b/community/phodav/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=phodav
-pkgver=2.3
-pkgrel=2
+pkgver=2.4
+pkgrel=0
pkgdesc="A WebDAV server using libsoup"
url="https://wiki.gnome.org/phodav"
arch="all"
@@ -12,14 +12,10 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lang chezdav chezdav-doc:chezdav
spice-webdavd:spice spice-webdavd-openrc:spice_openrc"
source="https://download.gnome.org/sources/phodav/$pkgver/phodav-$pkgver.tar.xz
spice-webdavd.initd
- meson_build-udev.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
-
- meson build/ \
+ meson \
--prefix=/usr \
--datadir=share \
--sysconfdir=/etc \
@@ -29,18 +25,13 @@ build() {
--buildtype=plain \
-Davahi=enabled \
-Dsystemd=disabled \
- -Dudev=enabled
-
- # print config options to log
- meson configure build/
-
- ninja -C build/
+ -Dudev=enabled \
+ . output
+ ninja -C output
}
package() {
- cd "$builddir"
-
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" ninja -C output install
rm -rf "$pkgdir"/usr/lib/systemd
}
@@ -68,9 +59,8 @@ spice_openrc() {
pkgdesc="Spice daemon for the DAV channel (OpenRC init scripts)"
install_if="spice-webdavd openrc"
mkdir -p "$subpkgdir"/etc/init.d
- install "$srcdir"/spice-webdavd.initd "$subpkgdir"/etc/init.d/spice-webdavd
+ install "$srcdir"/spice-webdavd.initd "$subpkgdir"/etc/init.d/spice-webdavd
}
-sha512sums="5f76ed0a4322707d117fc40a7bcab3a0bed7e53de52e0517e3ad79e3a6d93fc0200f6b54d8e001941d76ae22bd7f9ad158c0bee19354a316a18691057b65a002 phodav-2.3.tar.xz
-26db271c92760c38cf88bee6f8486e1c64aeaf81b19906783a3ea5e60054b2d5e7effdd26c59789ae3e964baa8bb498358724322b360bce229b45b6bee68f538 spice-webdavd.initd
-5ab7b8577ad78148a49d5218f839d4e82cce01167ca5d451b121f33c292ec5f6875e7d5d78b5f2969626e34b4225091a192f70c7916886651c39c60369cf2e7d meson_build-udev.patch"
+sha512sums="63f21843ccf62382bc48aa0c7f9ae6882431e59f590da5047f06e8cbbfcf8195744dcfc3b268997bf24ccf1f82f643b8189243f1ec80e60652a03c8c6a0f9b9e phodav-2.4.tar.xz
+1e10314f831840d9f54f38163bd518f42a378fe27b508639771b82610b4a434d4ec56c70a334dbfc7c8cd91160ba346751978f511c522577803248205dbcd211 spice-webdavd.initd"
diff --git a/community/phodav/meson_build-udev.patch b/community/phodav/meson_build-udev.patch
deleted file mode 100644
index 40f0eae36d..0000000000
--- a/community/phodav/meson_build-udev.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-https://gitlab.gnome.org/GNOME/phodav/commit/3925b28f356feef6b67ef95eae6de378df44100d
-
-This patch can be deleted with next releases (2.3+)
------------------------
---- a/meson.build
-+++ b/meson.build
-@@ -53,7 +53,7 @@
- )
- endif
-
--udev = dependency('udev', required : get_option('systemd'))
-+udev = dependency('udev', required : get_option('udev'))
- if udev.found()
- install_data(
- 'data/70-spice-webdavd.rules',
-
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -10,6 +10,10 @@
- type : 'feature',
- description : 'Install systemd units/configuration')
-
-+option('udev',
-+ type : 'feature',
-+ description : 'Install udev rules')
-+
- option('build-id',
- type : 'integer',
- value : 0,
-
diff --git a/community/phodav/spice-webdavd.initd b/community/phodav/spice-webdavd.initd
index 652ecd166b..9aefc6871d 100644
--- a/community/phodav/spice-webdavd.initd
+++ b/community/phodav/spice-webdavd.initd
@@ -1,13 +1,11 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
description="Spice guest utility for file sharing via WebDAV"
-command="/usr/sbin/spice-webdavd"
+command=/usr/sbin/spice-webdavd
command_args="--port 9843"
-pidfile="/run/${SVCNAME}.pid"
-command_background="yes"
-
depend() {
need dbus
use avahi