aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/collectd/APKBUILD10
1 files changed, 1 insertions, 9 deletions
diff --git a/community/collectd/APKBUILD b/community/collectd/APKBUILD
index 6d99289bda..c54a05c902 100644
--- a/community/collectd/APKBUILD
+++ b/community/collectd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=collectd
pkgver=5.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="The system statistics collection daemon"
url="https://collectd.org"
arch="all"
@@ -29,23 +29,18 @@ source="https://collectd.org/files/collectd-$pkgver.tar.bz2
gnu_source.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
# security fixes:
# 5.5.2-r0:
# - CVE-2016-6254
prepare() {
- cd "$builddir"
-
default_prepare
autoreconf -vif
}
build() {
- cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -70,13 +65,10 @@ build() {
}
check() {
- cd "$builddir"
-
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
chown root:collectd "$pkgdir"/etc/collectd/collectd.conf
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete