aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ocamlbuild/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/ocamlbuild/APKBUILD b/community/ocamlbuild/APKBUILD
index b8ba764f89..7f599a1556 100644
--- a/community/ocamlbuild/APKBUILD
+++ b/community/ocamlbuild/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
pkgname=ocamlbuild
pkgver=0.12.0
-pkgrel=2
+pkgrel=3
pkgdesc="Generic build tool with built-in rules for building OCaml library and programs"
url="https://github.com/ocaml/ocamlbuild"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
@@ -47,6 +47,7 @@ package() {
_libdev() {
pkgdesc="$pkgdesc (development files)"
depends="ocaml-$pkgname=$pkgver-r$pkgrel"
+ replaces="$pkgname" # for backward compatibility
local file; for file in '*.a' '*.cmx' '*.cmxa' '*.mli' '*.o'; do
_submv "usr/lib/ocaml/$pkgname/$file"
@@ -55,6 +56,7 @@ _libdev() {
_lib() {
pkgdesc="$pkgdesc (library)"
+ replaces="$pkgname" # for backward compatibility
_submv usr/lib/ocaml
}