aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/qt-creator/APKBUILD72
-rw-r--r--testing/qt-creator/fix-execinfo.patch56
-rw-r--r--testing/qt-creator/fix-headers-musl.patch11
-rw-r--r--testing/qt-creator/qtcreator-arm.patch78
4 files changed, 69 insertions, 148 deletions
diff --git a/testing/qt-creator/APKBUILD b/testing/qt-creator/APKBUILD
index c574cc8376..27bcd89b4a 100644
--- a/testing/qt-creator/APKBUILD
+++ b/testing/qt-creator/APKBUILD
@@ -1,62 +1,50 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt-creator
-pkgver=3.0.1
-pkgrel=1
+_pkgname=qt-creator-opensource-src
+pkgver=4.9.1
+pkgrel=0
pkgdesc="Lightweight and cross-platform IDE for Qt"
url="https://qt-project.org/wiki/Category:Tools::QtCreator"
-arch="all !aarch64 !ppc64le !s390x"
-license="LGPL-2.0 with exceptions"
-depends=""
-depends_dev=""
-makedepends="$depends_dev qt-dev qt-private-dev paxmark"
-install=""
-subpackages=""
-ldpath="/usr/lib/qtcreator:/usr/lib/qtcreator/plugins/Nokia"
-source="http://download.qt-project.org/official_releases/qtcreator/${pkgver%.*}/$pkgver/qt-creator-opensource-src-$pkgver.tar.gz
- qtcreator-arm.patch
- fix-headers-musl.patch
+arch="all !ppc64le !s390x"
+license="GPL-3.0-only WITH Qt-GPL-exception-1.0"
+depends="
+ qt5-qtbase-sqlite
+ qt5-qtquickcontrols
+ qt5-qtquickcontrols2
+ qt5-qtbase-dev
+ qt5-qttools-dev
+ "
+makedepends="
+ cmake
+ botan-dev
+ qt5-qtdeclarative-dev
+ qt5-qtscript-dev
+ qt5-qtquickcontrols2-dev
+ "
+ldpath="/usr/lib/qtcreator:/usr/lib/qtcreator/plugins"
+source="http://download.qt-project.org/official_releases/qtcreator/${pkgver%.*}/$pkgver/$_pkgname-$pkgver.tar.gz
fix-execinfo.patch
- qtcreator.desktop"
+ qtcreator.desktop
+ "
-_builddir="$srcdir"/qt-creator-opensource-src-$pkgver
+builddir="$srcdir"/$_pkgname-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
+ sed -i qtcreator.pri -e'/CONFIG += c++14/aCONFIG += use_system_botan'
}
build() {
- cd "$_builddir"
- qmake -r IDE_LIBRARY_BASENAME=lib || return 1
+ qmake-qt5
make CXX="${CXX:-g++}"
}
package() {
- cd "$_builddir"
- make install INSTALL_ROOT="$pkgdir"/usr || return 1
- paxmark -m "$pkgdir"/usr/bin/qtcreator \
- "$pkgdir"/usr/bin/qmlpuppet || return 1
+ make install INSTALL_ROOT="$pkgdir"/usr
install -Dm 644 "$srcdir"/qtcreator.desktop \
"$pkgdir"/usr/share/applications/qtcreator.desktop
}
-md5sums="1d736f4b3c25c25cf070c400a92e50c4 qt-creator-opensource-src-3.0.1.tar.gz
-9fb12108134fcbd716f884c150680056 qtcreator-arm.patch
-0e31a207fd72013b10dbf3cc1ebf0651 fix-headers-musl.patch
-f2645b7f79dde965ed57b948fadf19a7 fix-execinfo.patch
-f8b1f18e8d62cd4734bb676a97cee1dc qtcreator.desktop"
-sha256sums="829f1608c1c7304c907548315317520bf24cf5db711775d4d5f827607affdf98 qt-creator-opensource-src-3.0.1.tar.gz
-4bdf1ba9f12469de0092a9c09088e63090f2200224ede6939e565aa8c3901b20 qtcreator-arm.patch
-10e0e48ef7855c760e34d2bc50719b17ed12429a42090f95d3f7ddfb3562b57b fix-headers-musl.patch
-c460933c25ef1ff098a047b1403b90dd7ea439e13d06ec42fec32bf6b8b26390 fix-execinfo.patch
-849194d74b8fe1dd8ce78c39371256cd80a7cb3a79ec130dea36c8fd6155f88d qtcreator.desktop"
-sha512sums="fa8b2c4196136b310127daf308a5a99b0ef39b2e25db83930f959a034418a08590edbe8e19e6afea02c1d647602bb49c96df8db156d24f6b9b9246c1a93ead19 qt-creator-opensource-src-3.0.1.tar.gz
-b2d3a256db69512c693194234ff25d97ec58f19879b80d70d8fdac1f1f412aff1fddfe4d5fd0be98f77d7085d000aaa2ddb67cb1fe5d5a49be1d7fe8c95e7109 qtcreator-arm.patch
-f523b9da264265a01c7e3c6c298c3ea2098b1d15baa16a38dee6b3bd5b696dff6a5b7d32040fee2ad1d88bec3119a4d83029714e88cd56f5fb8f725694a742e6 fix-headers-musl.patch
-d145e037a7871a60309c0db70a30cbe1e7fac04756ff9445c8689cc56ac06838387db67ed8a3395200ecee0b7fd73108e3b5231b643f0eee6f9a02783f6278a8 fix-execinfo.patch
+sha512sums="f0b4b83e8103f493aceb41e8919bd3cbfac1aae3dd8862a2d844271bcf15f73d5dc67e87097a81800b1ac3efee057f35de4d58408f1baa4a4d1d46450319cf93 qt-creator-opensource-src-4.9.1.tar.gz
+0f9e03d73d0c25e9251fd1b323ea353c2b6bd50a3a75fae9cfe5e5d1bc0b201aa5735e0cbff02d00d1f84fe3cc3efea76d95da4b7c164d089e5aa8c705321b42 fix-execinfo.patch
b694063d2c91bfcf1cad25845c32158f35b8659f03ab9beebbadd98d06f01324ceafca682c2145025f6155c4f1d86bcba3bdcae4f54d5b5d71fc813aaf129a48 qtcreator.desktop"
diff --git a/testing/qt-creator/fix-execinfo.patch b/testing/qt-creator/fix-execinfo.patch
index 418ff73d5b..c3828c34b6 100644
--- a/testing/qt-creator/fix-execinfo.patch
+++ b/testing/qt-creator/fix-execinfo.patch
@@ -1,29 +1,51 @@
---- qt-creator-opensource-src-3.0.1/src/plugins/debugger/shared/backtrace.cpp.orig
-+++ qt-creator-opensource-src-3.0.1/src/plugins/debugger/shared/backtrace.cpp
-@@ -31,7 +31,7 @@
- #include <QDebug>
- #include <QProcess>
+--- a/src/plugins/qmldesigner/designercore/exceptions/exception.cpp 2015-04-21 17:56:56.000000000 +0200
++++ b/src/plugins/qmldesigner/designercore/exceptions/exception.cpp 2015-06-26 13:17:08.600350791 +0200
+@@ -31,7 +31,9 @@
+ #include "exception.h"
--#if defined(Q_OS_LINUX)
+ #ifdef Q_OS_LINUX
+#if defined(__GLIBC__)
+ #include <execinfo.h>
++#endif
+ #include <cxxabi.h>
+ #endif
+
+@@ -107,6 +109,7 @@
+ m_file(file)
+ {
+ #ifdef Q_OS_LINUX
++#ifdef __GLIBC__
+ void * array[50];
+ int nSize = backtrace(array, 50);
+ char ** symbols = backtrace_symbols(array, nSize);
+@@ -118,6 +121,7 @@
+
+ free(symbols);
+ #endif
++#endif
+
+ if (s_shouldAssert)
+ Q_ASSERT_X(false, function.toUtf8(), QString("%1:%2 - %3").arg(file).arg(line).arg(function).toUtf8());
+--- a/src/plugins/debugger/shared/backtrace.cpp 2015-04-21 17:56:56.000000000 +0200
++++ b/src/plugins/debugger/shared/backtrace.cpp 2015-06-26 13:14:54.295358053 +0200
+@@ -35,8 +35,10 @@
+ #if defined(Q_OS_LINUX)
#include <stdio.h>
#include <signal.h>
++#if defined(__GLIBC__)
#include <execinfo.h>
-@@ -44,7 +44,7 @@
+ #endif
++#endif
+
+ namespace Debugger {
+ namespace Internal {
+@@ -45,7 +47,7 @@
{
if (maxdepth == -1)
maxdepth = 200;
-#if defined(Q_OS_LINUX)
-+#if defined(__GLIBC__)
++#if defined(Q_OS_LINUX) && defined(__GLIBC__)
void *bt[200] = {0};
qDebug() << "BACKTRACE:";
int size = backtrace(bt, sizeof(bt) / sizeof(bt[0]));
-@@ -71,7 +71,7 @@
- /*
- void installSignalHandlers()
- {
--#if defined(Q_OS_LINUX)
-+#if defined(__GLIBC__)
- struct sigaction SignalAction;
-
- SignalAction.sa_sigaction = handler;
+
diff --git a/testing/qt-creator/fix-headers-musl.patch b/testing/qt-creator/fix-headers-musl.patch
deleted file mode 100644
index e3f4f1a6fd..0000000000
--- a/testing/qt-creator/fix-headers-musl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- qt-creator-opensource-src-3.0.1/src/libs/zeroconf/servicebrowser.cpp.orig
-+++ qt-creator-opensource-src-3.0.1/src/libs/zeroconf/servicebrowser.cpp
-@@ -45,7 +45,7 @@
- #include <signal.h>
- #ifdef Q_OS_UNIX
- // for select()
--# include <unistd.h>
-+# include <sys/select.h>
- #endif
-
- #include <QAtomicPointer>
diff --git a/testing/qt-creator/qtcreator-arm.patch b/testing/qt-creator/qtcreator-arm.patch
deleted file mode 100644
index ee6ad5326c..0000000000
--- a/testing/qt-creator/qtcreator-arm.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-https://bugreports.qt.io/browse/QTCREATORBUG-8107
-
-diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp
-index 917c385..4364a2e 100644
---- a/src/libs/3rdparty/botan/botan.cpp
-+++ b/src/libs/3rdparty/botan/botan.cpp
-@@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator
-
- #if (BOTAN_MP_WORD_BITS != 32)
- #error The mp_x86_32 module requires that BOTAN_MP_WORD_BITS == 32
-+#elif !defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
-+typedef Botan::u64bit dword;
- #endif
-
- #ifdef Q_OS_UNIX
-@@ -1118,6 +1120,7 @@ extern "C" {
- */
- inline word word_madd2(word a, word b, word* c)
- {
-+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- asm(
- ASM("mull %[b]")
- ASM("addl %[c],%[a]")
-@@ -1127,6 +1130,11 @@ inline word word_madd2(word a, word b, word* c)
- : "0"(a), "1"(b), [c]"g"(*c) : "cc");
-
- return a;
-+#else
-+ dword z = (dword)a * b + *c;
-+ *c = (word)(z >> BOTAN_MP_WORD_BITS);
-+ return (word)z;
-+#endif
- }
-
- /*
-@@ -1134,6 +1142,7 @@ inline word word_madd2(word a, word b, word* c)
- */
- inline word word_madd3(word a, word b, word c, word* d)
- {
-+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- asm(
- ASM("mull %[b]")
-
-@@ -1147,6 +1156,11 @@ inline word word_madd3(word a, word b, word c, word* d)
- : "0"(a), "1"(b), [c]"g"(c), [d]"g"(*d) : "cc");
-
- return a;
-+#else
-+ dword z = (dword)a * b + c + *d;
-+ *d = (word)(z >> BOTAN_MP_WORD_BITS);
-+ return (word)z;
-+#endif
- }
-
- }
-@@ -2315,7 +2329,7 @@ namespace Botan {
-
- extern "C" {
-
--#ifdef Q_OS_UNIX
-+#if defined(Q_OS_UNIX) && defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- /*
- * Helper Macros for x86 Assembly
- */
-diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
-index 6a9cbe0..8afec9e 100644
---- a/src/libs/3rdparty/botan/botan.h
-+++ b/src/libs/3rdparty/botan/botan.h
-@@ -81,7 +81,9 @@
- #endif
-
- #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
-+#if !defined(__arm__)
- #define BOTAN_TARGET_CPU_IS_X86_FAMILY
-+#endif
- #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
-
- #if defined(BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN) || \