aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/iperf3/APKBUILD8
-rw-r--r--main/iperf3/build-fixes.patch4
-rw-r--r--main/iperf3/remove-pg-flags.patch22
3 files changed, 17 insertions, 17 deletions
diff --git a/main/iperf3/APKBUILD b/main/iperf3/APKBUILD
index ba6adcc6dc..2439981753 100644
--- a/main/iperf3/APKBUILD
+++ b/main/iperf3/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iperf3
_pkgname=iperf
-pkgver=3.6
+pkgver=3.7
pkgrel=0
pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
url="https://github.com/esnet/iperf"
@@ -49,8 +49,8 @@ package() {
"$pkgdir"/etc/conf.d/$_pkgname
}
-sha512sums="0a1c8fd9b33369a2a018423cf33e63cfe7202ae411996f467199ae5b834ff7977d0e5c7e342f4f1b7d90c1c156453daa4dac9f94d11bb581d6d43c807538206d iperf3-3.6.tar.gz
+sha512sums="4a861a506d7e37958e1af62d1634d11c4937d5974bfce636d421aa80c88f038c96738d9e196a7667e38ef515f998b467d4ff3db30af7e3efea8d9ac8a63a61e7 iperf3-3.7.tar.gz
339fb04b41cce11e8ea8694d95c13af9c88e0d1143356d913ec810c9b11efa27212d585b5dcc49cc2eb860a6d8bc557092c8659d7d5cfe532c5afdb36f8eedf8 iperf.initd
fb5e155fff568a72488cc1511d30358835a48bcce309f8f46d040160932b4a4ccb85040c27c60dee477900a25bd34c50eac21d1d0bea984b40faa401be2ba7e8 iperf.confd
-126043503eebf84bccf26758f18715eaf81131e2fc9ef1fe829e55acb2f14e97db18e9b890b8bf13c230ac80c7537615272af4e072808e25bde8ddd6f326f198 build-fixes.patch
-ed0fb3a3af0dae3e9f58ff6643cb15defdd31f65cf966a6013fdf2a7fd67a7f8ef522a7c8f3269bd43d5ca991a86d758526c384ebc0984b1403bb24f61a1779b remove-pg-flags.patch"
+aef39e45bf63341b724b9131d8bfdf96702acc059e10d7d502053effa69a03097f64e9ba2a26c6a1e3e1567cf9a95013fc58b3b47623de79add14230bd820fa0 build-fixes.patch
+9334d51ec4bb4931272f972a83109dadd44123c9b46803a5b2d16e725576b860f93b62ae3d85be2a2d8a955cff24211da7675fe733a4f3ad8aaae005939a4097 remove-pg-flags.patch"
diff --git a/main/iperf3/build-fixes.patch b/main/iperf3/build-fixes.patch
index b797e70ea5..0f6804ecf3 100644
--- a/main/iperf3/build-fixes.patch
+++ b/main/iperf3/build-fixes.patch
@@ -7,7 +7,7 @@
+#include <sys/types.h>
#include "timer.h"
-
+ #include "iperf_time.h"
--- a/src/t_uuid.c
+++ b/src/t_uuid.c
@@ -28,6 +28,7 @@
@@ -17,4 +17,4 @@
+#include <sys/types.h>
#include "iperf_util.h"
-
+
diff --git a/main/iperf3/remove-pg-flags.patch b/main/iperf3/remove-pg-flags.patch
index 1ed47eebf5..3c0ab1321d 100644
--- a/main/iperf3/remove-pg-flags.patch
+++ b/main/iperf3/remove-pg-flags.patch
@@ -1,29 +1,29 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
-@@ -50,9 +50,9 @@
+@@ -58,9 +58,9 @@
iperf3_profile_SOURCES = main.c \
- $(libiperf_la_SOURCES)
+ $(libiperf_la_SOURCES)
-iperf3_profile_CFLAGS = -pg -g
+iperf3_profile_CFLAGS = -g
iperf3_profile_LDADD = libiperf.la
-iperf3_profile_LDFLAGS = -pg -g
+iperf3_profile_LDFLAGS = -g
+ endif
# Specify the sources and various flags for the test cases
- t_timer_SOURCES = t_timer.c
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -643,9 +643,9 @@
- iperf3_profile_SOURCES = main.c \
- $(libiperf_la_SOURCES)
+@@ -670,9 +670,9 @@
+ @ENABLE_PROFILING_TRUE@iperf3_profile_SOURCES = main.c \
+ @ENABLE_PROFILING_TRUE@ $(libiperf_la_SOURCES)
--iperf3_profile_CFLAGS = -pg -g
-+iperf3_profile_CFLAGS = -g
- iperf3_profile_LDADD = libiperf.la
--iperf3_profile_LDFLAGS = -pg -g
-+iperf3_profile_LDFLAGS = -g
+-@ENABLE_PROFILING_TRUE@iperf3_profile_CFLAGS = -pg -g
++@ENABLE_PROFILING_TRUE@iperf3_profile_CFLAGS = -g
+ @ENABLE_PROFILING_TRUE@iperf3_profile_LDADD = libiperf.la
+-@ENABLE_PROFILING_TRUE@iperf3_profile_LDFLAGS = -pg -g
++@ENABLE_PROFILING_TRUE@iperf3_profile_LDFLAGS = -g
# Specify the sources and various flags for the test cases
t_timer_SOURCES = t_timer.c