aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/lablgtk/APKBUILD2
-rw-r--r--community/ocaml-camlp4/APKBUILD (renamed from community/camlp4/APKBUILD)9
-rw-r--r--community/opam/APKBUILD2
-rw-r--r--testing/haxe/APKBUILD4
4 files changed, 10 insertions, 7 deletions
diff --git a/community/lablgtk/APKBUILD b/community/lablgtk/APKBUILD
index 2adb70e5cb..d7f99de6fc 100644
--- a/community/lablgtk/APKBUILD
+++ b/community/lablgtk/APKBUILD
@@ -9,7 +9,7 @@ url="http://lablgtk.forge.ocamlcore.org/"
arch="x86_64 ppc64le"
license="GPL"
depends_dev="lablgtk gtk+-dev gtkspell-dev librsvg-dev gtksourceview2-dev"
-depends="ocaml-findlib camlp4 ocaml"
+depends="ocaml-findlib ocaml-camlp4 ocaml"
makedepends="$depends $depends_dev"
subpackages="$pkgname-doc $pkgname-dev"
source="https://forge.ocamlcore.org/frs/download.php/1627/lablgtk-$pkgver.tar.gz"
diff --git a/community/camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index f153a86772..ea97256ea9 100644
--- a/community/camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -1,6 +1,7 @@
# Contributor: Jon Ong <jonongjs@rottenmage.com>
# Maintainer: Anil Madhavapeddy <anil@recoil.org>
-pkgname=camlp4
+pkgname=ocaml-camlp4
+_pkgname=camlp4
# NOTE: camlp4 version must match ocaml version!
pkgver=4.04
_versuffix='+1'
@@ -12,8 +13,10 @@ arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
depends="ocaml"
makedepends="ocamlbuild"
-source="$pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$pkgname/archive/$_pkgver.tar.gz"
-builddir="$srcdir/$pkgname-${_pkgver/+/-}"
+replaces="camlp4" # for backward compatibility
+provides="camlp4=$pkgver-r$pkgrel" # for backward compatibility
+source="$_pkgname-$_pkgver.tar.gz::https://github.com/ocaml/$_pkgname/archive/$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
build() {
cd "$builddir"
diff --git a/community/opam/APKBUILD b/community/opam/APKBUILD
index 2816d601b0..a234527260 100644
--- a/community/opam/APKBUILD
+++ b/community/opam/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="OCaml Package Manager"
url="https://opam.ocaml.org"
arch="all !x86 !armhf !s390x" # ocaml not avail on excluded platforms
license="LGPL-3.0"
-depends="ocaml camlp4 curl tar unzip rsync aspcud patch"
+depends="ocaml ocaml-camlp4 curl tar unzip rsync aspcud patch"
makedepends="$depends_dev"
source="https://github.com/ocaml/$pkgname/releases/download/$pkgver/$pkgname-full-$pkgver.tar.gz
fix-default-stubsdir.patch"
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index 1018a7c0fd..dfe41d374e 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -9,7 +9,7 @@ url="https://haxe.org"
arch="x86_64 aarch64 ppc64le"
license="GPL MIT LGPL" # http://haxe.org/foundation/open-source.html
depends=""
-makedepends="camlp4 ocaml neko-dev zlib-dev pcre-dev"
+makedepends="ocaml-camlp4 ocaml neko-dev zlib-dev pcre-dev"
options="!strip !makeflags"
install=""
subpackages="$pkgname-doc"
@@ -40,7 +40,7 @@ build() {
check() {
cd "$_builddir"
-
+
./haxe -version
./haxelib version
}