aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-fastavro/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-fastavro/APKBUILD b/testing/py3-fastavro/APKBUILD
new file mode 100644
index 0000000000..dbd989aba8
--- /dev/null
+++ b/testing/py3-fastavro/APKBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gennady Feldman <gena01@gmail.com>
+# Contributor: Gennady Feldman <gena01@gmail.com>
+pkgname=py3-fastavro
+_pkgname=fastavro
+pkgver=0.21.24
+pkgrel=0
+pkgdesc="Fast Avro for Python"
+url="https://github.com/fastavro/fastavro"
+arch="all"
+license="MIT"
+depends="py3-six"
+makedepends="py3-setuptools python3-dev cython3"
+checkdepends="py3-pytest py3-numpy"
+source="$pkgname-$pkgver.tar.gz::https://github.com/fastavro/fastavro/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ FASTAVRO_USE_CYTHON=1 python3 setup.py build
+}
+
+check() {
+ FASTAVRO_USE_CYTHON=1 python3 setup.py build_ext --inplace
+ PYTHONPATH=${PWD} python3 -m pytest -v tests
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="21b0afe86ff7dd202235da7f5e072621bfd4334efd1ba84bc026abbd907faab652e5c4bce248ae0417a20f56132263ed9300b563d030110092a2ce41902d66ff py3-fastavro-0.21.24.tar.gz"