aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/hylafax/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/main/hylafax/APKBUILD b/main/hylafax/APKBUILD
index 65bbf4fb71..e22046d120 100644
--- a/main/hylafax/APKBUILD
+++ b/main/hylafax/APKBUILD
@@ -16,13 +16,15 @@ source="ftp://ftp.hylafax.org/source/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd"
-_builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir"/$pkgname-$pkgver
+
prepare() {
- cd "$_builddir"
+ default_prepare || return 1
+ update_config_guess || return 1
}
build() {
- cd "$_builddir"
+ cd "$builddir"
# the configure script does not handle ccache or distcc
export CC=gcc
export CXX=g++
@@ -50,7 +52,7 @@ build() {
}
package(){
- cd "$_builddir"
+ cd "$builddir"
# this makefile has issues installing, it doesn't use the standard
# install - but the following seems to work
mkdir -p "${pkgdir}"/usr/bin "${pkgdir}"/usr/sbin