aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/php7-apcu/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/php7-apcu/APKBUILD b/community/php7-apcu/APKBUILD
index f0a0fb9254..4aa24569e4 100644
--- a/community/php7-apcu/APKBUILD
+++ b/community/php7-apcu/APKBUILD
@@ -4,14 +4,14 @@ pkgname=php7-apcu
_pkgreal=apcu
# release 5 is php7+
pkgver=5.1.12
-pkgrel=0
+pkgrel=1
pkgdesc="PHP extension APC User Cache"
-url="http://pecl.php.net/package/$_pkgreal"
+url="https://pecl.php.net/package/apcu"
arch="all"
license="PHP"
depends=""
makedepends="pcre-dev php7-dev autoconf"
-source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -31,6 +31,8 @@ package() {
cd "$builddir"
make INSTALL_ROOT="$pkgdir"/ install
+ install -D -m644 apc.php "$pkgdir"/usr/share/php7/apcu/apc.php
+
install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}