aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/py3-isort/APKBUILD (renamed from community/py-isort/APKBUILD)34
1 files changed, 8 insertions, 26 deletions
diff --git a/community/py-isort/APKBUILD b/community/py3-isort/APKBUILD
index e042e1ae41..0f03b3c23a 100644
--- a/community/py-isort/APKBUILD
+++ b/community/py3-isort/APKBUILD
@@ -1,51 +1,33 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-isort
+pkgname=py3-isort
_pkgname=isort
pkgver=4.3.19
pkgrel=0
-pkgdesc="A Python utility / library to sort Python imports"
+pkgdesc="Python library to sort Python imports"
url="https://github.com/timothycrosley/isort"
arch="noarch"
license="MIT"
# 3 out of 111 tests are failing. Needs upstream fix.
options="!check"
-makedepends="python2-dev python3-dev py-setuptools pytest py3-pytest"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+depends="py3-setuptools"
+makedepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces=py-isort # Backwards compatibility
+provides=py-isort=$pkgver-r$pkgrel # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
- pytest test_isort.py
pytest-3 test_isort.py
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3782f44bc7b5141105ff0e56d32e6ef80a231879d12b44c4e317209600fc0e597adf97600c17d890597e5cc31590be9d7ff2b45d0666ad518516ccb81343bb9c isort-4.3.19.tar.gz"