aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/shorewall-core/APKBUILD (renamed from testing/shorewall-core/APKBUILD)0
-rw-r--r--main/shorewall-lite/APKBUILD21
-rwxr-xr-xmain/shorewall-lite/shorewall-lite.initd66
-rw-r--r--main/shorewall-perl/APKBUILD17
-rw-r--r--main/shorewall/APKBUILD55
-rw-r--r--main/shorewall/shorewall.initd (renamed from testing/shorewall/shorewall.initd)0
-rw-r--r--main/shorewall6/APKBUILD (renamed from testing/shorewall6/APKBUILD)0
-rw-r--r--main/shorewall6/shorewall6.initd (renamed from testing/shorewall6/shorewall6.initd)0
-rw-r--r--testing/shorewall/APKBUILD52
9 files changed, 45 insertions, 166 deletions
diff --git a/testing/shorewall-core/APKBUILD b/main/shorewall-core/APKBUILD
index eff9d7ec76..eff9d7ec76 100644
--- a/testing/shorewall-core/APKBUILD
+++ b/main/shorewall-core/APKBUILD
diff --git a/main/shorewall-lite/APKBUILD b/main/shorewall-lite/APKBUILD
deleted file mode 100644
index 6a3ac266a6..0000000000
--- a/main/shorewall-lite/APKBUILD
+++ /dev/null
@@ -1,21 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-lite
-pkgver=4.2.11
-pkgrel=0
-pkgdesc="An iptables-based firewall whose config is handled by a normal Shorewall"
-url="http://www.shorewall.net/"
-arch="noarch"
-license="GPL-2"
-depends="iptables iproute2"
-#subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/4.2/shorewall-$pkgver/$pkgname-$pkgver.tar.bz2
- $pkgname.initd
- "
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
- install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
-}
-md5sums="cb34824f076fdff6b7457d85e124ea74 shorewall-lite-4.2.11.tar.bz2
-e55f393cd7bf2a12bf4b29fecce9ed71 shorewall-lite.initd"
diff --git a/main/shorewall-lite/shorewall-lite.initd b/main/shorewall-lite/shorewall-lite.initd
deleted file mode 100755
index bff41d8270..0000000000
--- a/main/shorewall-lite/shorewall-lite.initd
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/files/shorewall-lite,v 1.1 2007/05/20 22:32:36 mjolnir Exp $
-
-extra_commands="clear reset"
-extra_started_commands="refresh"
-
-depend() {
- need net
- provide firewall
- after ulogd
-}
-
-start() {
- ebegin "Starting firewall"
- /sbin/shorewall-lite -f start 1>/dev/null
- eend $?
-}
-
-stop() {
- ebegin "Stopping firewall"
- /sbin/shorewall-lite stop 1>/dev/null
- eend $?
-}
-
-restart() {
- # shorewall comes with its own control script that includes a
- # restart function, so refrain from calling svc_stop/svc_start
- # here. Note that this comment is required to fix bug 55576;
- # runscript.sh greps this script... (09 Jul 2004 agriffis)
- ebegin "Restarting firewall"
- if [ -f /var/lib/shorewall-lite/restore ] ; then
- /sbin/shorewall-lite restore
- else
- /sbin/shorewall-lite restart 1>/dev/null
- fi
- eend $?
-}
-
-clear() {
- # clear will remove all the rules and bring the system to an unfirewalled
- # state. (21 Nov 2004 eldad)
-
- ebegin "Clearing all firewall rules and setting policy to ACCEPT"
- /sbin/shorewall-lite clear && mark_service_stopped "${SVCNAME}"
- eend $?
-}
-
-reset() {
- # reset the packet and byte counters in the firewall
-
- ebegin "Resetting the packet and byte counters in the firewall"
- /sbin/shorewall-lite reset
- eend $?
-}
-
-refresh() {
- # refresh the rules involving the broadcast addresses of firewall
- # interfaces, the black list, traffic control rules and
- # ECN control rules
-
- ebegin "Refreshing firewall rules"
- /sbin/shorewall-lite refresh
- eend $?
-}
diff --git a/main/shorewall-perl/APKBUILD b/main/shorewall-perl/APKBUILD
deleted file mode 100644
index 8073380b9b..0000000000
--- a/main/shorewall-perl/APKBUILD
+++ /dev/null
@@ -1,17 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall-perl
-pkgver=4.2.11.1
-_v=4.2.11
-pkgrel=1
-pkgdesc="Shoreline Firewall Perl-based compiler"
-url="http://www.shorewall.net/"
-arch="all"
-license="GPL-2"
-depends="shorewall-common"
-source="http://www1.shorewall.net/pub/shorewall/${_v%.*}/shorewall-${_v}/$pkgname-$pkgver.tar.bz2"
-
-build() {
- cd "$srcdir"/$pkgname-$pkgver
- PREFIX="$pkgdir" ./install.sh || return 1
-}
-md5sums="e6f083624b20ad9016e3699740b06896 shorewall-perl-4.2.11.1.tar.bz2"
diff --git a/main/shorewall/APKBUILD b/main/shorewall/APKBUILD
index f651e79fd9..4a01321a44 100644
--- a/main/shorewall/APKBUILD
+++ b/main/shorewall/APKBUILD
@@ -1,17 +1,52 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.2.11
-pkgrel=1
-pkgdesc="Meta package for shorewall"
+pkgver=4.5.21.3
+
+_ver=$pkgver
+case $pkgver in
+*.*.*.*) _ver=${pkgver%.*};;
+esac
+
+pkgrel=0
+pkgdesc="An iptables front end for firewall configuration"
url="http://www.shorewall.net/"
-arch="all"
-license="GPL"
-depends="shorewall-shell"
-makedepends=""
-source=""
+arch="noarch"
+license="GPL-2"
+depends="shorewall-core perl iptables iproute2"
+# coreutils for install -T
+makedepends="coreutils bash"
+replaces=""
+subpackages="$pkgname-doc"
+source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
+ shorewall.initd
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
- mkdir -p "$pkgdir"
+ cd "$_builddir"
+ ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+}
+
+package() {
+ cd "$_builddir"
+ DESTDIR="$pkgdir" ./install.sh || return 1
+ rm -f "$pkgdir"/etc/init.d/shorewall
+ install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
+md5sums="baa980022dc7b5ec9b0a8dcede074779 shorewall-4.5.21.3.tar.bz2
+ac54901de1e876a18d1938df1512ce0d shorewall.initd"
+sha256sums="dd1160c077112264094478ee81d83c2757d6d72d0d8e7fe6bf000427282a8356 shorewall-4.5.21.3.tar.bz2
+8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd"
+sha512sums="e7bc8b8f0b91ec87d2e9c51472bbe9f1e3dd367faac83d0884e4479aab94d3d742535913241d79f63c39ceb0be451ad165939145ec16cfa8e3d05ffa373c012b shorewall-4.5.21.3.tar.bz2
+c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd"
diff --git a/testing/shorewall/shorewall.initd b/main/shorewall/shorewall.initd
index b2809757f0..b2809757f0 100644
--- a/testing/shorewall/shorewall.initd
+++ b/main/shorewall/shorewall.initd
diff --git a/testing/shorewall6/APKBUILD b/main/shorewall6/APKBUILD
index 696f8412ed..696f8412ed 100644
--- a/testing/shorewall6/APKBUILD
+++ b/main/shorewall6/APKBUILD
diff --git a/testing/shorewall6/shorewall6.initd b/main/shorewall6/shorewall6.initd
index b9f32aa461..b9f32aa461 100644
--- a/testing/shorewall6/shorewall6.initd
+++ b/main/shorewall6/shorewall6.initd
diff --git a/testing/shorewall/APKBUILD b/testing/shorewall/APKBUILD
deleted file mode 100644
index 4a01321a44..0000000000
--- a/testing/shorewall/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=shorewall
-pkgver=4.5.21.3
-
-_ver=$pkgver
-case $pkgver in
-*.*.*.*) _ver=${pkgver%.*};;
-esac
-
-pkgrel=0
-pkgdesc="An iptables front end for firewall configuration"
-url="http://www.shorewall.net/"
-arch="noarch"
-license="GPL-2"
-depends="shorewall-core perl iptables iproute2"
-# coreutils for install -T
-makedepends="coreutils bash"
-replaces=""
-subpackages="$pkgname-doc"
-source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
- shorewall.initd
- "
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
-}
-
-package() {
- cd "$_builddir"
- DESTDIR="$pkgdir" ./install.sh || return 1
- rm -f "$pkgdir"/etc/init.d/shorewall
- install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
-}
-
-md5sums="baa980022dc7b5ec9b0a8dcede074779 shorewall-4.5.21.3.tar.bz2
-ac54901de1e876a18d1938df1512ce0d shorewall.initd"
-sha256sums="dd1160c077112264094478ee81d83c2757d6d72d0d8e7fe6bf000427282a8356 shorewall-4.5.21.3.tar.bz2
-8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd"
-sha512sums="e7bc8b8f0b91ec87d2e9c51472bbe9f1e3dd367faac83d0884e4479aab94d3d742535913241d79f63c39ceb0be451ad165939145ec16cfa8e3d05ffa373c012b shorewall-4.5.21.3.tar.bz2
-c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd"