aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/scummvm/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/scummvm/APKBUILD b/testing/scummvm/APKBUILD
new file mode 100644
index 0000000000..26e324512f
--- /dev/null
+++ b/testing/scummvm/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=scummvm
+pkgver=1.5.0
+pkgrel=0
+pkgdesc="engine for several graphical adventure games"
+url="http://www.scummvm.org/"
+arch="all"
+license="GPL-2"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libogg-dev libvorbis-dev libtheora-dev zlib-dev libpng-dev sdl-dev alsa-lib-dev freetype-dev"
+install=""
+subpackages=""
+source="http://prdownloads.sourceforge.net/scummvm/scummvm-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/scummvm-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ # nasm disabled due to non-pic/pie compatible assembly
+ # dynamic plugins disabled due to sdl built without dlopen
+ ./configure \
+ --prefix=/usr \
+ --enable-all-engines \
+ --enable-release \
+ --disable-plugins \
+ --disable-nasm \
+ || exit 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="d71d1df5c8262556fedbe885972fbf6e scummvm-1.5.0.tar.bz2"