aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ocaml-camlp4/APKBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/community/ocaml-camlp4/APKBUILD b/community/ocaml-camlp4/APKBUILD
index 7d9e1deec6..ef0bc96282 100644
--- a/community/ocaml-camlp4/APKBUILD
+++ b/community/ocaml-camlp4/APKBUILD
@@ -4,13 +4,13 @@
pkgname=ocaml-camlp4
_pkgname=camlp4
# NOTE: camlp4 version must match ocaml version!
-pkgver=4.06.1
+pkgver=4.07.1
_pkgver="${pkgver%.*}+${pkgver##*.}"
_ocamlver=${pkgver%.*}
pkgrel=1
pkgdesc="Caml preprocessor and pretty-printer"
url="https://github.com/ocaml/camlp4/releases"
-arch="all !x86 !armhf !armv7 !s390x" # ocaml not avail on excluded platforms
+arch="aarch64 ppc64le x86_64" # reflect ocaml aport platforms
license="LGPL-2.0-or-later-WITH-linking-exception"
depends="ocaml-runtime=~$_ocamlver ocaml-ocamlbuild"
depends_dev="$pkgname=$pkgver-r$pkgrel"
@@ -25,16 +25,17 @@ builddir="$srcdir/$_pkgname-${_pkgver/+/-}"
build() {
cd "$builddir"
- ./configure
+ ./configure \
+ --bindir="/usr/bin" \
+ --libdir="/usr/lib/ocaml" \
+ --pkgdir="/usr/lib/ocaml"
make -j1 all camlp4/META
}
package() {
cd "$builddir"
- make BINDIR="$pkgdir/usr/bin" \
- LIBDIR="$pkgdir/usr/lib/ocaml" \
- PKGDIR="$pkgdir/usr/lib/ocaml" \
+ make DESTDIR="$pkgdir" \
install install-META
}
@@ -56,4 +57,4 @@ dev() {
rmdir "$subpkgdir"/$sitelib 2>/dev/null || true
}
-sha512sums="32be92c4e64a985a3d2880e2201351961a4b7138a8be6e3f17e9b8e038a1660d13596f29fe0249c8c4183cd8cd06277cebc58f42609c8d2028032e893490fe43 ocaml-camlp4-4.06+1.tar.gz"
+sha512sums="330d7f7a8ea6022df2d931a67e902f2e8bbf1026fbde08e1fd216763641a33005fde51b3b785363a05aa6717180f63b349badc1c107e05d13143b0db0e7051bc ocaml-camlp4-4.07+1.tar.gz"