aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/lua-ossl/APKBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/main/lua-ossl/APKBUILD b/main/lua-ossl/APKBUILD
index aa930c5b78..e732f521be 100644
--- a/main/lua-ossl/APKBUILD
+++ b/main/lua-ossl/APKBUILD
@@ -30,6 +30,24 @@ build() {
done
}
+check() {
+ local lver; for lver in $_luaversions; do
+ msg "Checking on lua$lver..."
+
+ # Lua sources in src/ are in non-standard layout, so we can't
+ # use them directly.
+ make -C "$builddir" DESTDIR="$builddir/.test$lver" install$lver
+
+ cd "$builddir"/regress
+ local file; for file in $(find . -type f -perm +111); do
+ echo "$file:" >&2
+ LUA_CPATH="../.test$lver/usr/lib/lua/$lver/?.so;;" \
+ LUA_PATH="../.test$lver/usr/share/lua/$lver/?.lua;;" \
+ lua$lver $file
+ done
+ done
+}
+
package() {
mkdir -p "$pkgdir"
}