aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/perl-test-mocktime/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/main/perl-test-mocktime/APKBUILD b/main/perl-test-mocktime/APKBUILD
index 43620f62f8..6744c498dc 100644
--- a/main/perl-test-mocktime/APKBUILD
+++ b/main/perl-test-mocktime/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-test-mocktime
-_pkgreal=Test-MockTime
-pkgver=0.15
+_pkgname=Test-MockTime
+pkgver=0.16
pkgrel=0
pkgdesc="Replaces actual time with simulated time"
url="http://search.cpan.org/dist/Test-MockTime/"
@@ -14,28 +14,30 @@ cpanmakedepends=" "
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/D/DD/DDICK/$_pkgreal-$pkgver.tar.gz"
-
-_builddir="$srcdir/$_pkgreal-$pkgver"
+source="http://search.cpan.org/CPAN/authors/id/D/DD/DDICK/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
+ cd "$builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make && make test
+ make
+}
+
+check() {
+ cd "$builddir"
+ make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-md5sums="af7374d01a2d6a0a9a341543ab8619e1 Test-MockTime-0.15.tar.gz"
-sha256sums="88210201de97aab66cb100edc2be3368c0062a9de635f4f8ec258a2267edcc48 Test-MockTime-0.15.tar.gz"
-sha512sums="8a91eb39e7ff68d6ac1cbd149ee8acdbdc2bf6c99bcd71decc38fb2c71f5ed6bdb32336c4e07a922e7d8dd1b2d084306a232e008a0a8587720fff60a3ba325d0 Test-MockTime-0.15.tar.gz"
+sha512sums="158026f9b1590131b51a004c0b8ecc7e190d0bd90da13ae56f645909e30ce6830deae1821874d71a1ad4d0dee84cd9e2b50aeacf7ef1d9cd465332823da0f927 Test-MockTime-0.16.tar.gz"