aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/plasma-integration/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/testing/plasma-integration/APKBUILD b/testing/plasma-integration/APKBUILD
new file mode 100644
index 0000000000..07ae546275
--- /dev/null
+++ b/testing/plasma-integration/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-integration
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="(LGPL-2.1-only OR LGPL-3.0-only) AND LGPL-2.1-only AND ((LGPL-2.1-only WITH Nokia-Qt-exception-1.1) OR (GPL-3.0-only WITH Nokia-Qt-exception-1.1))"
+depends="font-noto"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtx11extras-dev qt5-qtquickcontrols2-dev kconfig-dev kconfigwidgets-dev ki18n-dev kiconthemes-dev kio-dev knotifications-dev kwayland-dev kwidgetsaddons-dev kwindowsystem-dev kconfigwidgets-dev breeze-dev libxcursor-dev"
+checkdepends="xvfb-run"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-lang"
+options="!check" # Broken
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_DISABLE_FIND_PACKAGE_FontNotoSans=true \
+ -DCMAKE_DISABLE_FIND_PACKAGE_FontHack=true
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="427697f72e56f2727cafc2e70a50c0d2b9497aaea6b2f5806707242499534f15fb0c1ffae6def513ad2671673099824e242043d222dba84a17287f21bebeb437 plasma-integration-5.16.1.tar.xz"