aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/extra-cmake-modules/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/extra-cmake-modules/APKBUILD b/community/extra-cmake-modules/APKBUILD
index 09045bbd56..d0ce95f0b4 100644
--- a/community/extra-cmake-modules/APKBUILD
+++ b/community/extra-cmake-modules/APKBUILD
@@ -9,7 +9,7 @@ url="https://projects.kde.org/projects/kdesupport/extra-cmake-modules"
arch="noarch"
license="BSD-3-Clause"
depends="cmake"
-makedepends="py-sphinx"
+makedepends="py3-sphinx"
checkdepends="qt5-qtbase-dev qt5-qtquickcontrols2-dev"
subpackages="$pkgname-doc"
source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
@@ -17,7 +17,8 @@ source="http://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.
build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTING=ON
+ -DBUILD_TESTING=ON \
+ -DSphinx_BUILD_EXECUTABLE=/usr/bin/sphinx-build-3
make
}