aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/py3-httplib2/APKBUILD48
1 files changed, 11 insertions, 37 deletions
diff --git a/main/py3-httplib2/APKBUILD b/main/py3-httplib2/APKBUILD
index dfbb218822..c384e8be8e 100644
--- a/main/py3-httplib2/APKBUILD
+++ b/main/py3-httplib2/APKBUILD
@@ -1,55 +1,29 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-httplib2
+pkgname=py3-httplib2
_pkgname=httplib2
pkgver=0.13.1
-pkgrel=0
-pkgdesc="Python HTTP client library"
+pkgrel=1
+pkgdesc="Python3 HTTP client library"
url="https://github.com/httplib2/httplib2"
arch="noarch"
license="MIT"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${_pkgname}:_py2 py3-${_pkgname}:_py3"
+depends="python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-prepare() {
- default_prepare
- local python; for python in python2 python3; do
- cp -r "$builddir" "$builddir-$python"
- done
-}
+replaces="py-httplib2" # Backwards compatibility
+provides="py-httplib2=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- local python; for python in python2 python3; do
- cd "$builddir"-$python
- $python setup.py build
- done
+ cd "$builddir"
+ python3 setup.py build
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"-$python
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="c82e51481235d57660a7c93a639512c6b38bde60392f6da8e24b28f6083b54580d87f450bc333d5429fc2824cb0e367e3f9982ea97325a72c4289bec19fdc5e9 httplib2-0.13.1.tar.gz"