aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/mingw-w64-headers-bootstrap/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/mingw-w64-headers-bootstrap/APKBUILD b/testing/mingw-w64-headers-bootstrap/APKBUILD
new file mode 100644
index 0000000000..2d0a0d9e98
--- /dev/null
+++ b/testing/mingw-w64-headers-bootstrap/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=mingw-w64-headers-bootstrap
+pkgver=6.0.0
+pkgrel=0
+pkgdesc="Dummy headers for MinGW-w64 Windows"
+url="http://mingw-w64.sourceforge.net"
+arch="x86_64 x86"
+depends="!mingw-w64-winpthreads"
+license="none" # Headers with empty comments
+builddir="$srcdir/"
+
+case "$CARCH" in
+ x86_64) _target="x86_64-w64-mingw32" ;;
+ x86) _target="i686-w64-mingw32" ;;
+esac
+
+_dstring="/* Dummy header, which gets overriden, if winpthread library gets installed. */"
+
+package() {
+ mkdir -p "$pkgdir"/usr/${_target}/include
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_signal.h
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_time.h
+ echo "${_dstring}" > "$pkgdir"/usr/${_target}/include/pthread_unistd.h
+}
+