aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mutter/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/community/mutter/APKBUILD b/community/mutter/APKBUILD
index a88cb97906..4622ef9b9d 100644
--- a/community/mutter/APKBUILD
+++ b/community/mutter/APKBUILD
@@ -20,6 +20,13 @@ source="https://download.gnome.org/sources/mutter/${pkgver%.*}/mutter-$pkgver.ta
fix-cogl-path-build-ordering.patch
fixudev-req.patch"
+prepare() {
+ default_prepare
+ # disable unit test subdir, causes looping on builders and we don't run
+ # tests anyway
+ sed '/unit/d' -i cogl/tests/meson.build
+}
+
build() {
meson \
--prefix=/usr \
@@ -35,7 +42,7 @@ build() {
-Dremote_desktop=true \
-Dprofiler=false \
. output
- ninja -d explain -C output
+ ninja -C output
}
package() {