aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/raspberrypi/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index d0a30c6ce5..8f39c47a5b 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -2,7 +2,7 @@
pkgname=raspberrypi
pkgver=0.20181212
_commitid=7cbfbd38d9824535164f93a1d32c81a33a00ca31
-pkgrel=0
+pkgrel=1
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
arch="armhf armv7 aarch64"
@@ -33,6 +33,7 @@ build() {
-DARM64=$ARM64 \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_RPATH=/opt/vc/lib \
+ -DCMAKE_SHARED_LINKER_FLAGS="-Wl,--no-as-needed" \
$_sourcedir
make
}