aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/abuild/APKBUILD6
-rw-r--r--testing/openobex/APKBUILD34
2 files changed, 37 insertions, 3 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 8aed544419..989c7bebea 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgdesc="Script to build Alpine Packages"
pkgname=abuild
-pkgver=2.2
-pkgrel=1
+pkgver=2.3
+pkgrel=0
url=http://git.alpinelinux.org/cgit/abuild/
source="http://git.alpinelinux.org/cgit/abuild/snapshot/abuild-$pkgver.tar.bz2
"
@@ -21,4 +21,4 @@ package() {
install -m 644 abuild.conf "$pkgdir"/etc/abuild.conf
}
-md5sums="d5f6d5c9df7c7d00e2a26b245b37227d abuild-2.2.tar.bz2"
+md5sums="7c738e0018202160366b8329ec693502 abuild-2.3.tar.bz2"
diff --git a/testing/openobex/APKBUILD b/testing/openobex/APKBUILD
new file mode 100644
index 0000000000..4c83330cd6
--- /dev/null
+++ b/testing/openobex/APKBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openobex
+pkgver=1.5
+pkgrel=0
+pkgdesc="Implementation of the OBject EXchange (OBEX) protocol"
+url="http://dev.zuckschwerdt.org/openobex/"
+license="GPL LGPL"
+depends=
+makedepends="bluez-dev libusb-dev"
+subpackages="$pkgname-dev libopenobex"
+source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr \
+ --enable-apps \
+ --enable-irda \
+ --enable-bluetooth \
+ --enable-usb \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libopenobex() {
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libopenobex.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="fce1b82eafb74bde54fe117372393ba8 openobex-1.5.tar.bz2"