aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/ccache/APKBUILD4
-rw-r--r--main/fuse/APKBUILD8
-rw-r--r--main/fuse/fuse-iconv.patch6
-rw-r--r--main/module-init-tools/APKBUILD6
-rw-r--r--main/mpd/APKBUILD4
-rw-r--r--main/tmux/APKBUILD6
-rw-r--r--main/vala/APKBUILD4
-rw-r--r--main/vte/APKBUILD4
-rw-r--r--main/webkit/APKBUILD6
-rw-r--r--testing/freeswitch-sounds-es-mx-maria/APKBUILD26
-rw-r--r--testing/freeswitch-sounds-music-8000/APKBUILD27
-rw-r--r--testing/glade3/APKBUILD33
-rw-r--r--testing/openlldp/APKBUILD40
13 files changed, 150 insertions, 24 deletions
diff --git a/main/ccache/APKBUILD b/main/ccache/APKBUILD
index b7eb252eb7..bca01bbc66 100644
--- a/main/ccache/APKBUILD
+++ b/main/ccache/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ccache
-pkgver=3.0
+pkgver=3.0.1
pkgrel=0
pkgdesc="ccache is a compiler cache"
url="http://ccache.samba.org/"
@@ -33,4 +33,4 @@ package() {
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-cpp
ln -sf /usr/bin/ccache "$pkgdir"/usr/lib/ccache/bin/${CHOST}-c++
}
-md5sums="98145b8ad69a96bf1abf9a52d550e507 ccache-3.0.tar.gz"
+md5sums="15f2449899d9e8dc3aff6b86f97ab63e ccache-3.0.1.tar.gz"
diff --git a/main/fuse/APKBUILD b/main/fuse/APKBUILD
index 5f2d4eb61e..10cd34ba53 100644
--- a/main/fuse/APKBUILD
+++ b/main/fuse/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fuse
-pkgver=2.8.1
-pkgrel=1
+pkgver=2.8.4
+pkgrel=0
pkgdesc="A library that makes it possible to implement a filesystem in a userspace program."
url="http://fuse.sourceforge.net/"
license="GPL2"
@@ -57,6 +57,6 @@ _EOF_
}
-md5sums="0e3505ce90155983f1bc995eb2cf6fa7 fuse-2.8.1.tar.gz
-e5183506aabc5bf7795da52953d38888 fuse-iconv.patch
+md5sums="a26ec54e410bb826a387947b10c0fd2c fuse-2.8.4.tar.gz
+61db9e886d6f0a01ceca3731cba1f285 fuse-iconv.patch
5983726cfabf0830dffbbbf9a3abcddc fuse.initd"
diff --git a/main/fuse/fuse-iconv.patch b/main/fuse/fuse-iconv.patch
index 4710f576f2..0f930ce93a 100644
--- a/main/fuse/fuse-iconv.patch
+++ b/main/fuse/fuse-iconv.patch
@@ -1,5 +1,5 @@
diff --git a/lib/Makefile.am b/lib/Makefile.am
-index 3eec119..c7414ac 100644
+index 7b19fc2..db8352e 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -11,8 +11,10 @@ else
@@ -17,8 +17,8 @@ index 3eec119..c7414ac 100644
$(iconv_source) \
$(mount_source)
--libfuse_la_LDFLAGS = @libfuse_libs@ -version-number 2:8:1 \
-+libfuse_la_LDFLAGS += @libfuse_libs@ -version-number 2:8:1 \
+-libfuse_la_LDFLAGS = @libfuse_libs@ -version-number 2:8:4 \
++libfuse_la_LDFLAGS += @libfuse_libs@ -version-number 2:8:4 \
-Wl,--version-script,$(srcdir)/fuse_versionscript
libulockmgr_la_SOURCES = ulockmgr.c
diff --git a/main/module-init-tools/APKBUILD b/main/module-init-tools/APKBUILD
index 189f2f0d30..f0d9da8f77 100644
--- a/main/module-init-tools/APKBUILD
+++ b/main/module-init-tools/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanel Copa <ncopa@alpinelinux.org>
pkgname=module-init-tools
-pkgver=3.11.1
-pkgrel=1
+pkgver=3.12
+pkgrel=0
pkgdesc="Utilities for inserting and removing modules from the Linux kernel"
url="http://www.kernel.org"
license='GPL'
@@ -22,4 +22,4 @@ package() {
rm -r "$pkgdir/usr"
}
-md5sums="28dfcb9e24cdbeb12b99ac1eb8af7dea module-init-tools-3.11.1.tar.bz2"
+md5sums="8b2257ce9abef74c4a44d825d23140f3 module-init-tools-3.12.tar.bz2"
diff --git a/main/mpd/APKBUILD b/main/mpd/APKBUILD
index 3046c0002b..214d41c242 100644
--- a/main/mpd/APKBUILD
+++ b/main/mpd/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Sebastian Wicki <gandro@gmx.net>
# Maintainer: Natanael Copa <natanael.copa@gmail.com>
pkgname=mpd
-pkgver=0.15.10
+pkgver=0.15.11
pkgrel=0
pkgdesc="Music daemon that plays MP3, FLAC, and Ogg Vorbis files"
url="http://musicpd.org"
@@ -47,6 +47,6 @@ package() {
"$pkgdir"/var/lib/mpd/playlists \
"$pkgdir"/var/lib/mpd/music
}
-md5sums="fb18fa3ed5ff7e3719536a6603098df5 mpd-0.15.10.tar.bz2
+md5sums="a8f8afc641db6f789281fe14fcc8d8a9 mpd-0.15.11.tar.bz2
31d1515232d688d610d1664a0fb2a6a0 mpd.initd
dbd301041953a5cf9c2b9de8f23eb6bb mpd.confd"
diff --git a/main/tmux/APKBUILD b/main/tmux/APKBUILD
index fd3a8883c5..35dffc5ce9 100644
--- a/main/tmux/APKBUILD
+++ b/main/tmux/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tmux
-pkgver=1.2
-pkgrel=1
+pkgver=1.3
+pkgrel=0
pkgdesc="Tool to control multiple terminals from a single terminal"
url="http://tmux.sourceforge.net/"
license="BSD"
@@ -28,4 +28,4 @@ package() {
mv "$pkgdir"/usr/man "$pkgdir"/usr/share/
}
-md5sums="748fbe7bb5f86812e19bd6005ff21a5a tmux-1.2.tar.gz"
+md5sums="96e60cb206de2db0610b9fb6a64c2251 tmux-1.3.tar.gz"
diff --git a/main/vala/APKBUILD b/main/vala/APKBUILD
index 5501fbb4a1..4dadb23092 100644
--- a/main/vala/APKBUILD
+++ b/main/vala/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vala
-pkgver=0.8.1
+pkgver=0.9.3
pkgrel=0
pkgdesc="Compiler for the GObject type system"
url="http://live.gnome.org/Vala"
@@ -23,4 +23,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="9e3703950a84d2e57a6aa9354034705b vala-0.8.1.tar.gz"
+md5sums="23514f8cf312a1de8a5fd29b3246c698 vala-0.9.3.tar.gz"
diff --git a/main/vte/APKBUILD b/main/vte/APKBUILD
index a3bb81ae63..f8812a4b4c 100644
--- a/main/vte/APKBUILD
+++ b/main/vte/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vte
-pkgver=0.24.2
+pkgver=0.24.3
pkgrel=0
pkgdesc="Virtual Terminal Emulator library"
url="http://www.gnome.org"
@@ -26,4 +26,4 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="76d5bca203245fedf7eac6d434a16bd9 vte-0.24.2.tar.bz2"
+md5sums="3eba555eab7ccbbe5ca056bb203a14ab vte-0.24.3.tar.bz2"
diff --git a/main/webkit/APKBUILD b/main/webkit/APKBUILD
index 8f5afb1073..4442df10d0 100644
--- a/main/webkit/APKBUILD
+++ b/main/webkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=webkit
-pkgver=1.2.1
-pkgrel=1
+pkgver=1.2.3
+pkgrel=0
pkgdesc="portable web rendering engine WebKit for GTK+"
url="http://webkitgtk.org/"
license="LGPL BSD"
@@ -42,4 +42,4 @@ gtklauncher() {
"$subpkgdir"/usr/bin/GtkLauncher
}
-md5sums="eb6f473d8d7be56ecd226e7dd55dcb9b webkit-1.2.1.tar.gz"
+md5sums="0ab5c478a6f5b74a1ae96bf13a456662 webkit-1.2.3.tar.gz"
diff --git a/testing/freeswitch-sounds-es-mx-maria/APKBUILD b/testing/freeswitch-sounds-es-mx-maria/APKBUILD
new file mode 100644
index 0000000000..db0cd12c7b
--- /dev/null
+++ b/testing/freeswitch-sounds-es-mx-maria/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=freeswitch-sounds-es-mx-maria-44100
+pkgver="0"
+pkgrel=0
+pkgdesc="Sounds for freeswitch Spanish"
+url="http://files.freeswitch.org/"
+license="unknown"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://files.freeswitch.org/freeswitch-sounds-es-mx-maria-44100.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/sounds/
+ cp -ra "$srcdir"/ "$pkgdir"/usr/sounds
+}
+
+md5sums="a83a2e994741e4085016873d2d1c69a4 freeswitch-sounds-es-mx-maria-44100.tar.gz"
diff --git a/testing/freeswitch-sounds-music-8000/APKBUILD b/testing/freeswitch-sounds-music-8000/APKBUILD
new file mode 100644
index 0000000000..9cf9655bb5
--- /dev/null
+++ b/testing/freeswitch-sounds-music-8000/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=freeswitch-sounds-music-8000
+pkgver=1.0.8
+pkgrel=0
+pkgdesc="Sounds for freeswitch Music"
+url="http://files.freeswitch.org/"
+license="unknown"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://files.freeswitch.org/freeswitch-sounds-music-8000-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ return 0
+}
+
+package() {
+ mkdir -p "$pkgdir"/usr/sounds/
+ cp -ra "$srcdir"/ "$pkgdir"/usr/sounds
+}
+
+md5sums="f63ef3cc3507af079ae5c7b8b8a01e42 freeswitch-sounds-music-8000-$pkgver.tar.gz"
+
diff --git a/testing/glade3/APKBUILD b/testing/glade3/APKBUILD
new file mode 100644
index 0000000000..72e2c925a1
--- /dev/null
+++ b/testing/glade3/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=glade3
+pkgver=3.6.7
+pkgrel=0
+pkgdesc="a RAD tool to enable quick & easy development of user interfaces for GTK+"
+url="http://glade.gnome.org/"
+license="GPL"
+depends=
+makedepends="gtk+-dev libxml2-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://ftp.gnome.org/pub/GNOME/sources/glade3/3.6/glade3-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="0fbe06e4babb2adeaf9725577ff43395 glade3-3.6.7.tar.bz2"
diff --git a/testing/openlldp/APKBUILD b/testing/openlldp/APKBUILD
new file mode 100644
index 0000000000..140ff91d96
--- /dev/null
+++ b/testing/openlldp/APKBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=openlldp
+pkgver=0.4a
+_realver=0.4alpha
+pkgrel=0
+pkgdesc="Open Source implementation of the IEEE standard 802.1AB Link Layer Discovery Protocol (LLDP)"
+url="http://openlldp.sourceforge.net/"
+license="GPL"
+depends=
+makedepends=
+install=
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$_realver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+
+ # remove the 2 lines below (and this) if there is no init.d script
+ # install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
+ # install -m644 -D "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
+}
+
+md5sums="f48ffd632b96246cbf0f5c485dea3b01 openlldp-0.4alpha.tar.gz"