aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/marisa-trie/APKBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/testing/marisa-trie/APKBUILD b/testing/marisa-trie/APKBUILD
index f966471e63..6fa9102c61 100644
--- a/testing/marisa-trie/APKBUILD
+++ b/testing/marisa-trie/APKBUILD
@@ -19,19 +19,15 @@ prepare() {
build() {
case "$CARCH" in
- x86|x86_64)
- ./configure \
- --prefix=/usr \
- --disable-static \
- --enable-sse2
- ;;
- *)
- ./configure \
- --prefix=/usr \
- --disable-static
- ;;
+ x86|x86_64) sse2="--enable-sse2" ;;
+ *) sse2="--disable-sse2" ;;
esac
+ ./configure \
+ --prefix=/usr \
+ --disable-static \
+ $sse2
+
make
}