aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/tcsh/002-test_123-posix_fix.patch34
-rw-r--r--community/tcsh/APKBUILD13
2 files changed, 6 insertions, 41 deletions
diff --git a/community/tcsh/002-test_123-posix_fix.patch b/community/tcsh/002-test_123-posix_fix.patch
deleted file mode 100644
index 6ed59de387..0000000000
--- a/community/tcsh/002-test_123-posix_fix.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Author: Dan Theisen <djt@hxx.in>
-Date: Wed Jun 06 03:30:25 2018 -0800
-
-The following lines have a subtle change around [:blank:], changing it
-to [[:blank:]] instead. This is required because POSIX treats characters
-inside of brackets as a group of characters to match against. In this case,
-[[:space:]] means [] group of characters, and [:space:] is the group, as per:
-IEEE Std 1003.1-2017 (Revision of IEEE Std 1003.1-2008), Chapter 9
-http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap09.html
-
---- tcsh-6.20.00/tests/lexical.at.old 2018-06-06 02:20:16.787145186 -0700
-+++ tcsh-6.20.00/tests/lexical.at 2018-06-06 02:21:09.537890842 -0700
-@@ -567,10 +567,10 @@
- ]])
- AT_DATA([uniformity_test.csh],
- [[
--set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
-+set SERVICE_NAME_LOG = `cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g'`
- echo -n "$SERVICE_NAME_LOG" > ./output1
-
--cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
-+cat batchsystem.properties | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\s//g' | perl -pe 's/\)/\\\)/g' | perl -pe 's/\(/\\\(/g' > ./output2
-
- diff -uprN ./output1 ./output2 >& /dev/null
-
-@@ -587,7 +587,7 @@
- echo "(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP\)(HOST=db\)(PORT=1521\)\)(CONNECT_DATA=(SERVER=DEDICATED\)(SERVICE_NAME=bns03\)\)\)" > ./expected_result
-
- set string = "jdbc_url=jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=db)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=bns03)))"
--set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[:blank:]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
-+set SERVICE_NAME_LOG = `echo "$string" | grep '^jdbc_url' | sed -ne 's/^[^=]*=[^@]*@[[:blank:]]*\([^$]*\)$/\1/p' | perl -pe 's/\)/\\\)/g'`
-
- echo "$SERVICE_NAME_LOG" > ./actual_result
-
diff --git a/community/tcsh/APKBUILD b/community/tcsh/APKBUILD
index be3c77e225..897593d287 100644
--- a/community/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Milan P. Stanić <mps@arvanta.net>
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcsh
-pkgver=6.20.00
-pkgrel=3
+pkgver=6.21.00
+pkgrel=0
pkgdesc="extended C-shell"
url="https://github.com/tcsh-org/tcsh"
arch="all"
@@ -14,14 +14,14 @@ makedepends="ncurses-dev"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.pre-deinstall"
subpackages="$pkgname-doc"
options="!checkroot"
-source="$pkgname-$pkgver.tar.gz::http://http.debian.net/debian/pool/main/t/tcsh/${pkgname}_${pkgver}.orig.tar.gz
+_tarball="TCSH6_21_00"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tcsh-org/$pkgname/archive/$_tarball.tar.gz
001-sysmalloc.patch
- 002-test_123-posix_fix.patch
csh.login
csh.cshrc
"
-builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$_tarball"
build() {
cd "$builddir"
@@ -52,8 +52,7 @@ package() {
rm -rf "$pkgdir"/usr/share/locale
}
-sha512sums="c5635393c22341e62fb9a0b953ddf8871a876ab09deb08c98237f93afa9257b4a3381d1db65eefe769e22ef845db29ab7bc78773f1f609d73c8205689a6683e9 tcsh-6.20.00.tar.gz
+sha512sums="305380fd065ca4703ffba002358b41727056481573a78301cb8c2390d5fe1a4107af5d482db5abf26f0ce9f7193c8aeb0e34fedcc40971499be2e6dc13bf3405 tcsh-6.21.00.tar.gz
40149d8eb2fc0fe5184f3c24c7a1b728e881cc0048ccd37a986c3b2d2094499ec1c37ae2bae4c209fb8a847aa943e83e81f79e3d2f55c59990bc00d9d07f5a94 001-sysmalloc.patch
-b4c1afe04554d117b1402608bcdb243148c0c7b2442bdc10dde3ed6601db5e7c5a2341373f9bdc31fda8860e47a6e152cdcc4e3a8b273742037eebc624df282c 002-test_123-posix_fix.patch
0800e82a38db731154e8f04e5fad2919bb319fdbc626415f0f95d90b7f802c93071d106cee89f9a7201fb3cb69313b741f5f058aea8f89e86fe69613ca20557d csh.login
205628d2f0825aab9a1eb3b33b4de2377d010dbb3a098388fb11febda10ca2385ecacaa27c5428dbd7d9d711c913cddca72379c825bfb63385ebc3643253cb37 csh.cshrc"