aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-libarchive-c/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/testing/py3-libarchive-c/APKBUILD b/testing/py3-libarchive-c/APKBUILD
index 8569b4ce9b..9e121d12a8 100644
--- a/testing/py3-libarchive-c/APKBUILD
+++ b/testing/py3-libarchive-c/APKBUILD
@@ -1,13 +1,14 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-libarchive-c
-pkgver=2.8
-pkgrel=1
+pkgver=2.9
+pkgrel=0
pkgdesc="Python interface to libarchive"
url="https://github.com/Changaco/python-libarchive-c"
arch="noarch"
license="CC0-1.0"
depends="libarchive python3" # uses ffi
makedepends="python3-dev libarchive-dev py3-setuptools"
+checkdepends="py3-pytest py3-mock"
source="python-libarchive-c-$pkgver.tar.gz::https://github.com/Changaco/python-libarchive-c/archive/$pkgver.tar.gz"
builddir="$srcdir/python-libarchive-c-$pkgver"
@@ -17,19 +18,15 @@ prepare() {
}
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
- python3 setup.py check
+ py.test-3
}
package() {
- cd "$builddir"
- mkdir -p "$pkgdir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="789e2b700d0a57c424d133d274bac2fdc1d26027a45f3b4827ea3d47ceccd40cc1bbd4baa8e5abeb4ee42267ac589e36e94700f35354ff2dd0274f64c1fdba93 python-libarchive-c-2.8.tar.gz"
+sha512sums="282791cef6ff67aefc238ce1b40783e3952b366fc5c464fe99557e81d91e8057b9ec339c52535917c251f9a9bffdd3ec2773c91cbb6c9881d9ecb8572cf0fc5b python-libarchive-c-2.9.tar.gz"