aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/qt5-qtbase/APKBUILD9
1 files changed, 2 insertions, 7 deletions
diff --git a/main/qt5-qtbase/APKBUILD b/main/qt5-qtbase/APKBUILD
index aaf040dc5f..e53fe3d94c 100644
--- a/main/qt5-qtbase/APKBUILD
+++ b/main/qt5-qtbase/APKBUILD
@@ -5,7 +5,7 @@ _ver=${pkgver/_/-}
_ver=${_ver/beta0/beta}
_ver=${_ver/rc0/rc}
_V=${_ver/rc/RC}
-pkgrel=0
+pkgrel=1
pkgdesc="Qt5 - QtBase components"
url="http://qt-project.org/"
arch="all"
@@ -79,11 +79,6 @@ build() {
cd "$_builddir"
- case "$CTARGET" in
- arm*) _arch="";;
- *) _arch="-reduce-relocations";;
- esac
-
./configure -confirm-license -opensource \
-archdatadir "$_qt5_prefix" \
-bindir "$_qt5_prefix"/bin \
@@ -120,7 +115,7 @@ build() {
-system-xcb \
-system-zlib \
-translationdir "$_qt5_datadir"/translations \
- $_arch \
+ -no-reduce-relocations \
|| return 1
make || return 1
}