aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libnsl/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/community/libnsl/APKBUILD b/community/libnsl/APKBUILD
index 845e0832a4..f2af752499 100644
--- a/community/libnsl/APKBUILD
+++ b/community/libnsl/APKBUILD
@@ -8,27 +8,23 @@ url="https://github.com/thkukuk/libnsl"
arch="all"
license="LGPL-2.0-or-later"
makedepends="autoconf automake libtool libc-dev gettext-dev libtirpc-dev file"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-static $pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/thkukuk/$pkgname/archive/v$pkgver.tar.gz
nis_h.patch
cdefs.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
check() {
- cd "$builddir"
make check
}
prepare() {
default_prepare
- cd "$builddir"
./autogen.sh
sed 's/0.19/0.20/g' -i po/Makefile.in.in
}
build() {
- cd "$builddir"
./configure LIBS="-lintl" \
--build=$CBUILD \
--host=$CHOST \
@@ -37,7 +33,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}