aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-blessings/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/py3-blessings/APKBUILD b/testing/py3-blessings/APKBUILD
index a72509d948..42d9f4f777 100644
--- a/testing/py3-blessings/APKBUILD
+++ b/testing/py3-blessings/APKBUILD
@@ -3,14 +3,14 @@
pkgname=py3-blessings
_pkgname=blessings
pkgver=1.7
-pkgrel=3
+pkgrel=4
pkgdesc="Python library for terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
depends="py3-six"
makedepends="py3-setuptools"
-checkdepends="py3-nose"
+options="!check" # tests require a real terminal
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,10 +18,6 @@ build() {
python3 setup.py build
}
-check() {
- nosetests build/lib
-}
-
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}