aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/nodejs/APKBUILD2
-rw-r--r--main/nodejs/link-with-libatomic-on-mips32.patch24
2 files changed, 9 insertions, 17 deletions
diff --git a/main/nodejs/APKBUILD b/main/nodejs/APKBUILD
index c813e90dce..86d9c900d2 100644
--- a/main/nodejs/APKBUILD
+++ b/main/nodejs/APKBUILD
@@ -128,4 +128,4 @@ npm() {
sha512sums="d9dd5f3ef6e2cba180efaa564d9dfbb4c44ec95675085522a5658db62cac24e3a7c9ef725a5532a08f86e8e87b640a6258679a476a67749c78fa6ff95cd657d3 node-v10.14.1.tar.gz
9d09a88074bf0093f35c5b610e73ebf4c5381df2a2b29feb69da1af0b18776a683b13f1276375bbcfc60936cc27769539e1f01b4ba94b22cad2d5f4daae14c46 dont-run-gyp-files-for-bundled-deps.patch
-9256f6f84978c4fea7ac625bbf3934e85de5d00393d28a50df2c234a7309fdf5c49b59da1825e8817a3794044af0219c698a0c57367cc6f1fe0ef813f837aa97 link-with-libatomic-on-mips32.patch"
+4fd3f10bd82d1e851ed000169c2635c001a4a051283edf96f1efb2260e2d395199dd5843f79f1cff8f2c0c65462c44241c508ea67835dfbd9880d9196fae290a link-with-libatomic-on-mips32.patch"
diff --git a/main/nodejs/link-with-libatomic-on-mips32.patch b/main/nodejs/link-with-libatomic-on-mips32.patch
index b8f6a144b7..c4988a0d9f 100644
--- a/main/nodejs/link-with-libatomic-on-mips32.patch
+++ b/main/nodejs/link-with-libatomic-on-mips32.patch
@@ -1,22 +1,14 @@
--- a/node.gyp
+++ b/node.gyp
-@@ -247,6 +247,9 @@
+@@ -478,6 +478,11 @@
'msvs_disabled_warnings!': [4244],
'conditions': [
-+ [ '(target_arch=="mips" or target_arch=="mipsel") and mips_arch_variant!="r6"', {
-+ 'libraries': [ '-latomic' ],
++ [ 'host_arch=="mips" or host_arch=="mipsel"', {
++ 'link_settings': {
++ 'libraries': [ '-latomic' ],
++ },
+ }],
- [ 'node_intermediate_lib_type=="static_library" and '
- 'node_shared=="true" and OS=="aix"', {
- # For AIX, shared lib is linked by static lib and .exp. In the
-@@ -934,6 +937,9 @@
- ],
-
- 'conditions': [
-+ [ '(target_arch=="mips" or target_arch=="mipsel") and mips_arch_variant!="r6"', {
-+ 'libraries': [ '-latomic' ],
-+ }],
- [ 'node_use_openssl=="true"', {
- 'defines': [
- 'HAVE_OPENSSL=1',
+ [ 'node_code_cache_path!=""', {
+ 'sources': [ '<(node_code_cache_path)' ]
+ }, {