aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ruby-rspec-core/APKBUILD2
-rw-r--r--community/ruby-rspec-expectations/APKBUILD2
-rw-r--r--community/ruby-rspec-mocks/APKBUILD2
-rw-r--r--community/ruby-rspec/APKBUILD6
4 files changed, 6 insertions, 6 deletions
diff --git a/community/ruby-rspec-core/APKBUILD b/community/ruby-rspec-core/APKBUILD
index 4f23548246..f58d3818cd 100644
--- a/community/ruby-rspec-core/APKBUILD
+++ b/community/ruby-rspec-core/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="RSpec runner and formatters"
url="https://relishapp.com/rspec/rspec-core/"
arch="noarch"
license="MIT"
-depends="ruby ruby-rspec-support>=${pkgver%.*}.0"
+depends="ruby ruby-rspec-support~=${pkgver%.*}"
options="!check" # rspec's tests are written in rspec
source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
gemspec.patch"
diff --git a/community/ruby-rspec-expectations/APKBUILD b/community/ruby-rspec-expectations/APKBUILD
index ef1e322c73..87c4551727 100644
--- a/community/ruby-rspec-expectations/APKBUILD
+++ b/community/ruby-rspec-expectations/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Provides a readable API to express expected outcomes of a code example
url="https://relishapp.com/rspec/rspec-expectations/"
arch="noarch"
license="MIT"
-depends="ruby ruby-diff-lcs ruby-rspec-support>=${pkgver%.*}.0"
+depends="ruby ruby-diff-lcs ruby-rspec-support~=${pkgver%.*}"
options="!check" # rspec's tests are written in rspec
source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
gemspec.patch"
diff --git a/community/ruby-rspec-mocks/APKBUILD b/community/ruby-rspec-mocks/APKBUILD
index fb4db6e8b6..5c0583eff0 100644
--- a/community/ruby-rspec-mocks/APKBUILD
+++ b/community/ruby-rspec-mocks/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="RSpec's 'test double' framework, with support for stubbing and mocking"
url="https://relishapp.com/rspec/rspec-mocks/"
arch="noarch"
license="MIT"
-depends="ruby ruby-diff-lcs ruby-rspec-support>=${pkgver%.*}.0"
+depends="ruby ruby-diff-lcs ruby-rspec-support~=${pkgver%.*}"
options="!check" # rspec's tests are written in rspec
source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
gemspec.patch"
diff --git a/community/ruby-rspec/APKBUILD b/community/ruby-rspec/APKBUILD
index 9a219d1b54..15a7dffd42 100644
--- a/community/ruby-rspec/APKBUILD
+++ b/community/ruby-rspec/APKBUILD
@@ -9,9 +9,9 @@ url="http://rspec.info/"
arch="noarch"
license="MIT"
depends="ruby
- ruby-rspec-core>=${pkgver%.*}.0
- ruby-rspec-expectations>=${pkgver%.*}.0
- ruby-rspec-mocks>=${pkgver%.*}.0"
+ ruby-rspec-core~=${pkgver%.*}
+ ruby-rspec-expectations~=${pkgver%.*}
+ ruby-rspec-mocks~=${pkgver%.*}"
options="!check" # no tests provided
source="$pkgname-$pkgver.tar.gz::https://github.com/rspec/$_gemname/archive/v$pkgver.tar.gz
gemspec.patch"