aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libplist/APKBUILD16
-rw-r--r--community/libplist/Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch340
2 files changed, 352 insertions, 4 deletions
diff --git a/community/libplist/APKBUILD b/community/libplist/APKBUILD
index 97d833664c..46af262f0d 100644
--- a/community/libplist/APKBUILD
+++ b/community/libplist/APKBUILD
@@ -2,14 +2,21 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libplist
pkgver=2.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="A library to handle Apple Property List format whereas it's binary or XML"
url="https://libimobiledevice.org/"
arch="all"
license="GPL-2.0-or-later AND LGPL-2.1-or-later"
-makedepends="py3-setuptools swig python3-dev glib-dev cython3"
+makedepends="py3-setuptools swig python3-dev glib-dev cython
+ autoconf automake libtool"
subpackages="$pkgname-static $pkgname-dev py3-$pkgname:_py3 $pkgname-util $pkgname++:cxx"
-source="https://www.libimobiledevice.org/downloads/libplist-$pkgver.tar.bz2"
+source="https://www.libimobiledevice.org/downloads/libplist-$pkgver.tar.bz2
+ Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch"
+
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
build() {
./configure \
@@ -51,4 +58,5 @@ cxx() {
mv "$pkgdir"/usr/lib/*++.so.* "$subpkgdir"/usr/lib/
}
-sha512sums="81508bf6773483528816725c3b5b868563b84fd7810999404072e5ea9efa7fc9f11ef997f32208e4421aa26b15edd0c65f87c67c1472e8c4e356f1e9fe7740ee libplist-2.0.0.tar.bz2"
+sha512sums="81508bf6773483528816725c3b5b868563b84fd7810999404072e5ea9efa7fc9f11ef997f32208e4421aa26b15edd0c65f87c67c1472e8c4e356f1e9fe7740ee libplist-2.0.0.tar.bz2
+92e0d125f8f4e605ab7fcaa37cc62104f027d706aa42d923f1efc877b5000092865a4e347fef2a276030faca9e0053551bbcc72de488f7e246dd1cc00d3523e1 Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch"
diff --git a/community/libplist/Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch b/community/libplist/Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch
new file mode 100644
index 0000000000..ab773d322c
--- /dev/null
+++ b/community/libplist/Updated-ac_python_devel.m4-to-newer-ax_python_devel.m4.patch
@@ -0,0 +1,340 @@
+From 42bb64ba966082b440cb68cbdadf317f44710017 Mon Sep 17 00:00:00 2001
+From: Nikias Bassen <nikias@gmx.li>
+Date: Thu, 4 Apr 2019 01:51:02 +0300
+Subject: [PATCH] Updated ac_python_devel.m4 to newer ax_python_devel.m4
+
+---
+ m4/{ac_python_devel.m4 => ax_python_devel.m4} | 188 ++++++++++++------
+ 1 file changed, 123 insertions(+), 65 deletions(-)
+ rename m4/{ac_python_devel.m4 => ax_python_devel.m4} (61%)
+
+diff --git a/m4/ac_python_devel.m4 b/m4/ax_python_devel.m4
+similarity index 61%
+rename from m4/ac_python_devel.m4
+rename to m4/ax_python_devel.m4
+index 545c6078..44dbd83e 100644
+--- a/m4/ac_python_devel.m4
++++ b/m4/ax_python_devel.m4
+@@ -1,10 +1,10 @@
+ # ===========================================================================
+-# http://autoconf-archive.cryp.to/ac_python_devel.html
++# https://www.gnu.org/software/autoconf-archive/ax_python_devel.html
+ # ===========================================================================
+ #
+ # SYNOPSIS
+ #
+-# AC_PYTHON_DEVEL([version])
++# AX_PYTHON_DEVEL([version])
+ #
+ # DESCRIPTION
+ #
+@@ -12,8 +12,8 @@
+ # in your configure.ac.
+ #
+ # This macro checks for Python and tries to get the include path to
+-# 'Python.h'. It provides the $(PYTHON_CPPFLAGS) and $(PYTHON_LDFLAGS)
+-# output variables. It also exports $(PYTHON_EXTRA_LIBS) and
++# 'Python.h'. It provides the $(PYTHON_CPPFLAGS) and $(PYTHON_LIBS) output
++# variables. It also exports $(PYTHON_EXTRA_LIBS) and
+ # $(PYTHON_EXTRA_LDFLAGS) for embedding Python in your code.
+ #
+ # You can search for some particular version of Python by passing a
+@@ -31,18 +31,15 @@
+ # If you need to use this macro for an older Python version, please
+ # contact the authors. We're always open for feedback.
+ #
+-# LAST MODIFICATION
++# LICENSE
+ #
+-# 2008-04-12
+-#
+-# COPYLEFT
+-#
+-# Copyright (c) 2008 Sebastian Huber <sebastian-huber@web.de>
+-# Copyright (c) 2008 Alan W. Irwin <irwin@beluga.phys.uvic.ca>
+-# Copyright (c) 2008 Rafael Laboissiere <rafael@laboissiere.net>
+-# Copyright (c) 2008 Andrew Collier <colliera@ukzn.ac.za>
+-# Copyright (c) 2008 Matteo Settenvini <matteo@member.fsf.org>
+-# Copyright (c) 2008 Horst Knorr <hk_classes@knoda.org>
++# Copyright (c) 2009 Sebastian Huber <sebastian-huber@web.de>
++# Copyright (c) 2009 Alan W. Irwin
++# Copyright (c) 2009 Rafael Laboissiere <rafael@laboissiere.net>
++# Copyright (c) 2009 Andrew Collier
++# Copyright (c) 2009 Matteo Settenvini <matteo@member.fsf.org>
++# Copyright (c) 2009 Horst Knorr <hk_classes@knoda.org>
++# Copyright (c) 2013 Daniel Mullner <muellner@math.stanford.edu>
+ #
+ # This program is free software: you can redistribute it and/or modify it
+ # under the terms of the GNU General Public License as published by the
+@@ -55,7 +52,7 @@
+ # Public License for more details.
+ #
+ # You should have received a copy of the GNU General Public License along
+-# with this program. If not, see <http://www.gnu.org/licenses/>.
++# with this program. If not, see <https://www.gnu.org/licenses/>.
+ #
+ # As a special exception, the respective Autoconf Macro's copyright owner
+ # gives unlimited permission to copy, distribute and modify the configure
+@@ -66,11 +63,14 @@
+ # all other use of the material that constitutes the Autoconf Macro.
+ #
+ # This special exception to the GPL applies to versions of the Autoconf
+-# Macro released by the Autoconf Macro Archive. When you make and
+-# distribute a modified version of the Autoconf Macro, you may extend this
+-# special exception to the GPL to apply to your modified version as well.
++# Macro released by the Autoconf Archive. When you make and distribute a
++# modified version of the Autoconf Macro, you may extend this special
++# exception to the GPL to apply to your modified version as well.
+
+-AC_DEFUN([AC_PYTHON_DEVEL],[
++#serial 21
++
++AU_ALIAS([AC_PYTHON_DEVEL], [AX_PYTHON_DEVEL])
++AC_DEFUN([AX_PYTHON_DEVEL],[
+ #
+ # Allow the use of a (user set) custom python version
+ #
+@@ -90,8 +90,8 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+ #
+ AC_MSG_CHECKING([for a version of Python >= '2.1.0'])
+ ac_supports_python_ver=`$PYTHON -c "import sys; \
+- ver = sys.version.split()[[0]]; \
+- print(ver >= '2.1.0')"`
++ ver = sys.version.split ()[[0]]; \
++ print (ver >= '2.1.0')"`
+ if test "$ac_supports_python_ver" != "True"; then
+ if test -z "$PYTHON_NOVERSIONCHECK"; then
+ AC_MSG_RESULT([no])
+@@ -99,7 +99,7 @@ AC_DEFUN([AC_PYTHON_DEVEL],[
+ This version of the AC@&t@_PYTHON_DEVEL macro
+ doesn't work properly with versions of Python before
+ 2.1.0. You may need to re-run configure, setting the
+-variables PYTHON_CPPFLAGS, PYTHON_LDFLAGS, PYTHON_SITE_PKG,
++variables PYTHON_CPPFLAGS, PYTHON_LIBS, PYTHON_SITE_PKG,
+ PYTHON_EXTRA_LIBS and PYTHON_EXTRA_LDFLAGS by hand.
+ Moreover, to disable this check, set PYTHON_NOVERSIONCHECK
+ to something else than an empty string.
+@@ -117,10 +117,10 @@ to something else than an empty string.
+ if test -n "$1"; then
+ AC_MSG_CHECKING([for a version of Python $1])
+ ac_supports_python_ver=`$PYTHON -c "import sys; \
+- ver = sys.version.split()[[0]]; \
+- print(ver >= '2.1.0')"`
++ ver = sys.version.split ()[[0]]; \
++ print (ver $1)"`
+ if test "$ac_supports_python_ver" = "True"; then
+- AC_MSG_RESULT([yes])
++ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([this package requires Python $1.
+@@ -137,7 +137,7 @@ variable to configure. See ``configure --help'' for reference.
+ #
+ AC_MSG_CHECKING([for the distutils Python package])
+ ac_distutils_result=`$PYTHON -c "import distutils" 2>&1`
+- if test -z "$ac_distutils_result"; then
++ if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+@@ -151,14 +151,17 @@ $ac_distutils_result])
+ # Check for Python include path
+ #
+ AC_MSG_CHECKING([for Python include path])
+- if type $PYTHON-config; then
+- PYTHON_CPPFLAGS=`$PYTHON-config --includes`
+- fi
+ if test -z "$PYTHON_CPPFLAGS"; then
+ python_path=`$PYTHON -c "import distutils.sysconfig; \
+- print(distutils.sysconfig.get_python_inc());"`
++ print (distutils.sysconfig.get_python_inc ());"`
++ plat_python_path=`$PYTHON -c "import distutils.sysconfig; \
++ print (distutils.sysconfig.get_python_inc (plat_specific=1));"`
+ if test -n "${python_path}"; then
+- python_path="-I$python_path"
++ if test "${plat_python_path}" != "${python_path}"; then
++ python_path="-I$python_path -I$plat_python_path"
++ else
++ python_path="-I$python_path"
++ fi
+ fi
+ PYTHON_CPPFLAGS=$python_path
+ fi
+@@ -169,29 +172,80 @@ $ac_distutils_result])
+ # Check for Python library path
+ #
+ AC_MSG_CHECKING([for Python library path])
+- if type $PYTHON-config; then
+- PYTHON_LDFLAGS=`$PYTHON-config --ldflags`
+- fi
+- if test -z "$PYTHON_LDFLAGS"; then
++ if test -z "$PYTHON_LIBS"; then
+ # (makes two attempts to ensure we've got a version number
+ # from the interpreter)
+- py_version=`$PYTHON -c "from distutils.sysconfig import *; \
+- print(' '.join(get_config_vars('VERSION')))"`
+- if test "$py_version" = "[None]"; then
++ ac_python_version=`cat<<EOD | $PYTHON -
++
++# join all versioning strings, on some systems
++# major/minor numbers could be in different list elements
++from distutils.sysconfig import *
++e = get_config_var('VERSION')
++if e is not None:
++ print(e)
++EOD`
++
++ if test -z "$ac_python_version"; then
+ if test -n "$PYTHON_VERSION"; then
+- py_version=$PYTHON_VERSION
++ ac_python_version=$PYTHON_VERSION
+ else
+- py_version=`$PYTHON -c "import sys; \
+- print(sys.version[[:3]]")`
++ ac_python_version=`$PYTHON -c "import sys; \
++ print (sys.version[[:3]])"`
+ fi
+ fi
+
+- PYTHON_LDFLAGS=`$PYTHON -c "from distutils.sysconfig import *; \
+- print('-L' + get_python_lib(0,1) + \
+- ' -lpython');"`$py_version
++ # Make the versioning information available to the compiler
++ AC_DEFINE_UNQUOTED([HAVE_PYTHON], ["$ac_python_version"],
++ [If available, contains the Python version number currently in use.])
++
++ # First, the library directory:
++ ac_python_libdir=`cat<<EOD | $PYTHON -
++
++# There should be only one
++import distutils.sysconfig
++e = distutils.sysconfig.get_config_var('LIBDIR')
++if e is not None:
++ print (e)
++EOD`
++
++ # Now, for the library:
++ ac_python_library=`cat<<EOD | $PYTHON -
++
++import distutils.sysconfig
++c = distutils.sysconfig.get_config_vars()
++if 'LDVERSION' in c:
++ print ('python'+c[['LDVERSION']])
++else:
++ print ('python'+c[['VERSION']])
++EOD`
++
++ # This small piece shamelessly adapted from PostgreSQL python macro;
++ # credits goes to momjian, I think. I'd like to put the right name
++ # in the credits, if someone can point me in the right direction... ?
++ #
++ if test -n "$ac_python_libdir" -a -n "$ac_python_library"
++ then
++ # use the official shared library
++ ac_python_library=`echo "$ac_python_library" | sed "s/^lib//"`
++ PYTHON_LIBS="-L$ac_python_libdir -l$ac_python_library"
++ else
++ # old way: use libpython from python_configdir
++ ac_python_libdir=`$PYTHON -c \
++ "from distutils.sysconfig import get_python_lib as f; \
++ import os; \
++ print (os.path.join(f(plat_specific=1, standard_lib=1), 'config'));"`
++ PYTHON_LIBS="-L$ac_python_libdir -lpython$ac_python_version"
++ fi
++
++ if test -z "PYTHON_LIBS"; then
++ AC_MSG_ERROR([
++ Cannot determine location of your Python DSO. Please check it was installed with
++ dynamic libraries enabled, or try setting PYTHON_LIBS by hand.
++ ])
++ fi
+ fi
+- AC_MSG_RESULT([$PYTHON_LDFLAGS])
+- AC_SUBST([PYTHON_LDFLAGS])
++ AC_MSG_RESULT([$PYTHON_LIBS])
++ AC_SUBST([PYTHON_LIBS])
+
+ #
+ # Check for site packages
+@@ -199,7 +253,7 @@ $ac_distutils_result])
+ AC_MSG_CHECKING([for Python site-packages path])
+ if test -z "$PYTHON_SITE_PKG"; then
+ PYTHON_SITE_PKG=`$PYTHON -c "import distutils.sysconfig; \
+- print(distutils.sysconfig.get_python_lib(0,0))"`
++ print (distutils.sysconfig.get_python_lib(0,0));"`
+ fi
+ AC_MSG_RESULT([$PYTHON_SITE_PKG])
+ AC_SUBST([PYTHON_SITE_PKG])
+@@ -211,7 +265,7 @@ $ac_distutils_result])
+ if test -z "$PYTHON_EXTRA_LIBS"; then
+ PYTHON_EXTRA_LIBS=`$PYTHON -c "import distutils.sysconfig; \
+ conf = distutils.sysconfig.get_config_var; \
+- print(conf('LOCALMODLIBS'), conf('LIBS'))"`
++ print (conf('LIBS') + ' ' + conf('SYSLIBS'))"`
+ fi
+ AC_MSG_RESULT([$PYTHON_EXTRA_LIBS])
+ AC_SUBST(PYTHON_EXTRA_LIBS)
+@@ -223,7 +277,7 @@ $ac_distutils_result])
+ if test -z "$PYTHON_EXTRA_LDFLAGS"; then
+ PYTHON_EXTRA_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; \
+ conf = distutils.sysconfig.get_config_var; \
+- print(conf('LINKFORSHARED'))"`
++ print (conf('LINKFORSHARED'))"`
+ fi
+ AC_MSG_RESULT([$PYTHON_EXTRA_LDFLAGS])
+ AC_SUBST(PYTHON_EXTRA_LDFLAGS)
+@@ -232,24 +286,32 @@ $ac_distutils_result])
+ # final check to see if everything compiles alright
+ #
+ AC_MSG_CHECKING([consistency of all components of python development environment])
+- AC_LANG_PUSH([C])
+ # save current global flags
+- LIBS="$ac_save_LIBS $PYTHON_LDFLAGS"
++ ac_save_LIBS="$LIBS"
++ ac_save_LDFLAGS="$LDFLAGS"
++ ac_save_CPPFLAGS="$CPPFLAGS"
++ LIBS="$ac_save_LIBS $PYTHON_LIBS $PYTHON_EXTRA_LIBS $PYTHON_EXTRA_LIBS"
++ LDFLAGS="$ac_save_LDFLAGS $PYTHON_EXTRA_LDFLAGS"
+ CPPFLAGS="$ac_save_CPPFLAGS $PYTHON_CPPFLAGS"
+- AC_TRY_LINK([
+- #include <Python.h>
+- ],[
+- Py_Initialize();
+- ],[pythonexists=yes],[pythonexists=no])
++ AC_LANG_PUSH([C])
++ AC_LINK_IFELSE([
++ AC_LANG_PROGRAM([[#include <Python.h>]],
++ [[Py_Initialize();]])
++ ],[pythonexists=yes],[pythonexists=no])
++ AC_LANG_POP([C])
++ # turn back to default flags
++ CPPFLAGS="$ac_save_CPPFLAGS"
++ LIBS="$ac_save_LIBS"
++ LDFLAGS="$ac_save_LDFLAGS"
+
+ AC_MSG_RESULT([$pythonexists])
+
+- if test ! "$pythonexists" = "yes"; then
+- AC_MSG_ERROR([
++ if test ! "x$pythonexists" = "xyes"; then
++ AC_MSG_FAILURE([
+ Could not link test program to Python. Maybe the main Python library has been
+ installed in some non-standard library path. If so, pass it to configure,
+- via the LDFLAGS environment variable.
+- Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
++ via the LIBS environment variable.
++ Example: ./configure LIBS="-L/usr/non-standard-path/python/lib"
+ ============================================================================
+ ERROR!
+ You probably have to install the development version of the Python package
+@@ -258,10 +320,6 @@ $ac_distutils_result])
+ ])
+ PYTHON_VERSION=""
+ fi
+- AC_LANG_POP
+- # turn back to default flags
+- CPPFLAGS="$ac_save_CPPFLAGS"
+- LIBS="$ac_save_LIBS"
+
+ #
+ # all done!