aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/github-cli/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/github-cli/APKBUILD b/community/github-cli/APKBUILD
index 7651fbc2fb..6d13c94aec 100644
--- a/community/github-cli/APKBUILD
+++ b/community/github-cli/APKBUILD
@@ -2,17 +2,22 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=github-cli
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="GitHub issue tracker client"
url="http://packages.python.org/github-cli/"
arch="noarch"
license="BSD"
-depends="python2 py-simplejson"
+depends="python2 py-simplejson py-setuptools"
makedepends="py-distutils-extra"
-install=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.zip::https://github.com/jsmits/$pkgname/archive/$pkgver.zip"
builddir="$srcdir"/$pkgname-$pkgver
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+}
+
build() {
cd "$builddir"
python2 setup.py build
@@ -25,6 +30,4 @@ package() {
install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
}
-md5sums="9e6b53ebebef3a6b07b6a3984e976c61 github-cli-1.0.0.zip"
-sha256sums="f30367a79243d6f9cc600185eff3f6074f0ffa6b46361be32ca198467a7467b8 github-cli-1.0.0.zip"
sha512sums="ba57bb1a6842da951da2c807e49f0b1f18c36e754dad567cc912dff6e979cd6aefd6063f10bd99d32542f73d8001a5bfcebd54471f445259dc218386e00fe61d github-cli-1.0.0.zip"